From 08dcbfe97ff978d93691bfc708be97256b4d593b Mon Sep 17 00:00:00 2001
From: Renato Botelho <garga@FreeBSD.org>
Date: Thu, 29 Jun 2006 11:08:18 +0000
Subject: LiON (Lund's Input Output Library) is a C library to quickly develop
 programs that are event-driven, networked, non-blocking and portable. It
 includes a simple API to do any networking, file I/O and pipes.

It is multiplatform and runs on POSIX-like systems and Windows.

WWW: http://www.lundman.net/wiki/index.php/LiON

PR:		ports/99589
Submitted by:	Marco Molteni <molterSPAM@gufiSPAM.org>
---
 devel/lion/Makefile  | 40 ++++++++++++++++++++++++++++++++++++++++
 devel/lion/distinfo  |  3 +++
 devel/lion/pkg-descr |  7 +++++++
 devel/lion/pkg-plist | 17 +++++++++++++++++
 4 files changed, 67 insertions(+)
 create mode 100644 devel/lion/Makefile
 create mode 100644 devel/lion/distinfo
 create mode 100644 devel/lion/pkg-descr
 create mode 100644 devel/lion/pkg-plist

(limited to 'devel/lion')

diff --git a/devel/lion/Makefile b/devel/lion/Makefile
new file mode 100644
index 000000000000..5993d2d93c0f
--- /dev/null
+++ b/devel/lion/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for:	LiON
+# Date created:		June 2006
+# Whom:			Marco Molteni <molterSPAM@gufiSPAM.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	lion
+DISTVERSION=	20060301
+CATEGORIES=	devel net
+MASTER_SITES=	http://www.lundman.net/ftp/
+EXTRACT_SUFX=	.tgz
+
+MAINTAINER=	molterSPAM@gufiSPAM.org
+COMMENT=	Multi-platform, event-driven, simple networking library
+
+# TODO
+# add support for SSL/TLS/OpenSSL
+WRKSRC=		${WRKDIR}/${PORTNAME}
+USE_GMAKE=	yes
+ALL_TARGET=	default
+
+INCLUDES=	base64.h connections.h io.h lfnmatch.h lgroup.h lion.h \
+		lion_rcsid.h lion_types.h misc.h pipe.h sockets.h \
+		timers.h tls.h udp.h zlib.h
+
+post-patch:
+	@${REINPLACE_CMD} -e 's,<time.h>,<sys/time.h>,' \
+		${WRKSRC}/timers.h
+	@${REINPLACE_CMD} -E 's,^(CC|LDFLAGS) *=,\1 ?=,' \
+		${WRKSRC}/Makefile
+
+do-install:
+	${INSTALL_DATA} ${WRKSRC}/liblion.a ${PREFIX}/lib
+	@${MKDIR} ${PREFIX}/include/lion
+.for i in ${INCLUDES}
+	${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/include/lion
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/lion/distinfo b/devel/lion/distinfo
new file mode 100644
index 000000000000..a4df77ab58fa
--- /dev/null
+++ b/devel/lion/distinfo
@@ -0,0 +1,3 @@
+MD5 (lion-20060301.tgz) = 56935033716c358ccadea476536d5e61
+SHA256 (lion-20060301.tgz) = f86a47124064633f9976e14a402cb937470f518a604a798f929b04a219002032
+SIZE (lion-20060301.tgz) = 210284
diff --git a/devel/lion/pkg-descr b/devel/lion/pkg-descr
new file mode 100644
index 000000000000..41a8682a81e5
--- /dev/null
+++ b/devel/lion/pkg-descr
@@ -0,0 +1,7 @@
+LiON (Lund's Input Output Library) is a C library to quickly develop
+programs that are event-driven, networked, non-blocking and portable.
+It includes a simple API to do any networking, file I/O and pipes.
+
+It is multiplatform and runs on POSIX-like systems and Windows.
+
+WWW: http://www.lundman.net/wiki/index.php/LiON
diff --git a/devel/lion/pkg-plist b/devel/lion/pkg-plist
new file mode 100644
index 000000000000..83ef05c0271c
--- /dev/null
+++ b/devel/lion/pkg-plist
@@ -0,0 +1,17 @@
+include/lion/base64.h
+include/lion/connections.h
+include/lion/io.h
+include/lion/lfnmatch.h
+include/lion/lgroup.h
+include/lion/lion.h
+include/lion/lion_rcsid.h
+include/lion/lion_types.h
+include/lion/misc.h
+include/lion/pipe.h
+include/lion/sockets.h
+include/lion/timers.h
+include/lion/tls.h
+include/lion/udp.h
+include/lion/zlib.h
+@dirrm include/lion
+lib/liblion.a
-- 
cgit v1.2.3