From 86598107565cc46aab9d842c231dc796be0d9994 Mon Sep 17 00:00:00 2001
From: "Simon L. B. Nielsen" <simon@FreeBSD.org>
Date: Wed, 1 Jun 2005 08:42:58 +0000
Subject: Add cogito 0.10, cogito, GIT - the content tracker.

The GIT itself is merely an extremely fast and flexible filesystem-based
database designed to store directory trees with regard to their history.
The top layer is a SCM-like tool Cogito which enables human beings to work
with the database in a manner to a degree similar to other SCM tools (like
CVS, BitKeeper or Monotone).

PR:		ports/81698
Submitted by:	Michael Seyfert <michaels@sdf.lonestar.org>
Approved by:	erwin (mentor)
---
 devel/cogito/Makefile             | 69 +++++++++++++++++++++++++++++++++++
 devel/cogito/distinfo             |  2 ++
 devel/cogito/files/patch-Makefile | 14 ++++++++
 devel/cogito/pkg-descr            | 12 +++++++
 devel/cogito/pkg-plist            | 75 +++++++++++++++++++++++++++++++++++++++
 5 files changed, 172 insertions(+)
 create mode 100644 devel/cogito/Makefile
 create mode 100644 devel/cogito/distinfo
 create mode 100644 devel/cogito/files/patch-Makefile
 create mode 100644 devel/cogito/pkg-descr
 create mode 100644 devel/cogito/pkg-plist

(limited to 'devel/cogito')

diff --git a/devel/cogito/Makefile b/devel/cogito/Makefile
new file mode 100644
index 000000000000..f83745d06492
--- /dev/null
+++ b/devel/cogito/Makefile
@@ -0,0 +1,69 @@
+# Ports collection makefile for: cogito
+# Date created:		31 May 2005
+# Whom:			Michael Seyfert <michaels@sdf.lonestar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	cogito
+PORTVERSION=	0.10
+CATEGORIES=	devel
+MASTER_SITES=	http://www.kernel.org/pub/software/scm/cogito/ \
+		http://www.uk.kernel.org/pub/software/scm/cogito/ \
+		http://www.us.kernel.org/pub/software/scm/cogito/
+
+MAINTAINER=	michaels@sdf.lonestar.org
+COMMENT=	Cogito, GIT - the content tracker
+
+LIB_DEPENDS=	curl:${PORTSDIR}/ftp/curl
+RUN_DEPENDS=	bash:${PORTSDIR}/shells/bash2 \
+		rsync:${PORTSDIR}/net/rsync
+
+USE_BZIP2=	yes
+USE_GMAKE=	yes
+
+# We set HOME to PREFIX, this is the easiest way to install in
+# the proper location without patching.
+MAKE_ENV+=	HOME=${PREFIX} CPATH=${PREFIX}/include LIBRARY_PATH=${PREFIX}/lib
+CFLAGS+=	-I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+STRIP_FILES=	${PREFIX}/bin/git-cat-file \
+		${PREFIX}/bin/git-check-files \
+		${PREFIX}/bin/git-checkout-cache \
+		${PREFIX}/bin/git-commit-tree \
+		${PREFIX}/bin/git-convert-cache \
+		${PREFIX}/bin/git-diff-cache \
+		${PREFIX}/bin/git-diff-files \
+		${PREFIX}/bin/git-diff-tree \
+		${PREFIX}/bin/git-diff-tree-helper \
+		${PREFIX}/bin/git-export \
+		${PREFIX}/bin/git-fsck-cache \
+		${PREFIX}/bin/git-http-pull \
+		${PREFIX}/bin/git-init-db \
+		${PREFIX}/bin/git-local-pull \
+		${PREFIX}/bin/git-ls-files \
+		${PREFIX}/bin/git-ls-tree \
+		${PREFIX}/bin/git-merge-base \
+		${PREFIX}/bin/git-merge-cache \
+		${PREFIX}/bin/git-mktag \
+		${PREFIX}/bin/git-read-tree \
+		${PREFIX}/bin/git-rev-list \
+		${PREFIX}/bin/git-rev-tree \
+		${PREFIX}/bin/git-rpull \
+		${PREFIX}/bin/git-rpush \
+		${PREFIX}/bin/git-tar-tree \
+		${PREFIX}/bin/git-unpack-file \
+		${PREFIX}/bin/git-update-cache \
+		${PREFIX}/bin/git-write-blob \
+		${PREFIX}/bin/git-write-tree
+
+post-install:
+	${STRIP_CMD} ${STRIP_FILES}
+	${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/contrib/gitfeedmaillist.sh ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+	${MKDIR} ${DOCSDIR}
+	${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/README ${DOCSDIR}
+	${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/Documentation/core-git.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cogito/distinfo b/devel/cogito/distinfo
new file mode 100644
index 000000000000..9cf4e73e6f0a
--- /dev/null
+++ b/devel/cogito/distinfo
@@ -0,0 +1,2 @@
+MD5 (cogito-0.10.tar.bz2) = 5bce32ffd5c7de01fb4785b44a48b11d
+SIZE (cogito-0.10.tar.bz2) = 89000
diff --git a/devel/cogito/files/patch-Makefile b/devel/cogito/files/patch-Makefile
new file mode 100644
index 000000000000..bdf490073fd7
--- /dev/null
+++ b/devel/cogito/files/patch-Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile.orig
++++ Makefile
+@@ -80,7 +80,7 @@
+ 	LIB_OBJS += ppc/sha1.o ppc/sha1ppc.o
+ else
+ 	SHA1_HEADER=<openssl/sha.h>
+-	LIBS += -lssl
++	LIBS += -lssl -lcrypto
+ endif
+ endif
+ 
diff --git a/devel/cogito/pkg-descr b/devel/cogito/pkg-descr
new file mode 100644
index 000000000000..b402fc520970
--- /dev/null
+++ b/devel/cogito/pkg-descr
@@ -0,0 +1,12 @@
+       Cogito, GIT - the content tracker
+
+The GIT itself is merely an extremely fast and flexible filesystem-based
+database designed to store directory trees with regard to their history.
+The top layer is a SCM-like tool Cogito which enables human beings to work
+with the database in a manner to a degree similar to other SCM tools (like
+CVS, BitKeeper or Monotone).
+
+WWW: http://kernel.org/pub/software/scm/cogito/
+
+- Michael Seyfert
+michaels@sdf.lonestar.org
diff --git a/devel/cogito/pkg-plist b/devel/cogito/pkg-plist
new file mode 100644
index 000000000000..f38ae529b0fb
--- /dev/null
+++ b/devel/cogito/pkg-plist
@@ -0,0 +1,75 @@
+bin/gitfeedmaillist.sh
+bin/cg-add
+bin/cg-admin-lsobj
+bin/cg-admin-uncommit
+bin/cg-branch-add
+bin/cg-branch-ls
+bin/cg-cancel
+bin/cg-clone
+bin/cg-commit
+bin/cg-diff
+bin/cg-export
+bin/cg-help
+bin/cg-init
+bin/cg-log
+bin/cg-ls
+bin/cg-merge
+bin/cg-mkpatch
+bin/cg-patch
+bin/cg-pull
+bin/cg-restore
+bin/cg-rm
+bin/cg-seek
+bin/cg-status
+bin/cg-tag
+bin/cg-tag-ls
+bin/cg-update
+bin/cg-version
+bin/git-resolve-script
+bin/commit-id
+bin/git-apply-patch-script
+bin/git-cat-file
+bin/git-check-files
+bin/git-checkout-cache
+bin/git-commit-tree
+bin/git-convert-cache
+bin/git-diff-cache
+bin/git-diff-files
+bin/git-diff-tree
+bin/git-diff-tree-helper
+bin/git-export
+bin/git-fsck-cache
+bin/git-http-pull
+bin/git-init-db
+bin/git-local-pull
+bin/git-ls-files
+bin/git-ls-tree
+bin/git-merge-base
+bin/git-merge-cache
+bin/git-merge-one-file-script
+bin/git-mktag
+bin/git-prune-script
+bin/git-pull-script
+bin/git-read-tree
+bin/git-rev-list
+bin/git-rev-tree
+bin/git-rpull
+bin/git-rpush
+bin/git-tag-script
+bin/git-tar-tree
+bin/git-unpack-file
+bin/git-update-cache
+bin/git-write-blob
+bin/git-write-tree
+bin/parent-id
+bin/tree-id
+lib/cogito/cg-Xdiffdo
+lib/cogito/cg-Xlib
+lib/cogito/cg-Xmergefile
+@dirrm lib/cogito
+@unexec rmdir %D/lib/ 2>/dev/null || true
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/core-git.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec rmdir %D/share/doc/ 2>/dev/null || true
+@unexec rmdir %D/share/ 2>/dev/null || true
-- 
cgit v1.2.3