From e13a0e860d6204d9ad45da79dd35538ac03f829c Mon Sep 17 00:00:00 2001
From: Tom McLaughlin <tmclaugh@FreeBSD.org>
Date: Thu, 10 Nov 2005 04:41:45 +0000
Subject: - Add fix for stricter mcs in 1.1.9.x - Include bsd.mono.mk.

Approved by:    ahze (mentor)
Project by:     BSD# <http://www.mono-project.com/Mono:FreeBSD>
---
 comms/gfax/Makefile               |  5 +++--
 comms/gfax/files/patch-src_gui.cs | 13 +++++++++++++
 comms/gfax/pkg-plist              |  4 ++--
 3 files changed, 18 insertions(+), 4 deletions(-)
 create mode 100644 comms/gfax/files/patch-src_gui.cs

(limited to 'comms/gfax')

diff --git a/comms/gfax/Makefile b/comms/gfax/Makefile
index 936437f3956a..d8f4cc325bac 100644
--- a/comms/gfax/Makefile
+++ b/comms/gfax/Makefile
@@ -2,13 +2,13 @@
 # Date created:			20 January 2002
 # Whom:				John Merryweather Cooper <jmcoopr@webmail.bmi.net>
 #
-# $Id: Makefile,v 1.8 2005/06/15 02:10:28 tmclau02 Exp $
 # $FreeBSD$
+#   $Id: Makefile,v 1.12 2005/11/10 01:21:02 tmclau02 Exp $
 #
 
 PORTNAME=	gfax
 PORTVERSION=	0.7.3
-PORTREVISION=	2
+PORTREVISION=	4
 CATEGORIES=	comms print gnome
 MASTER_SITES=	http://gfax.cowlug.org/
 DISTNAME=	${PORTNAME}-${PORTVERSION}-1
@@ -41,4 +41,5 @@ post-patch:
 	@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
 		${WRKSRC}/scripts/printer-setup.sh
 
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
 .include <bsd.port.mk>
diff --git a/comms/gfax/files/patch-src_gui.cs b/comms/gfax/files/patch-src_gui.cs
new file mode 100644
index 000000000000..b818371fb6c0
--- /dev/null
+++ b/comms/gfax/files/patch-src_gui.cs
@@ -0,0 +1,13 @@
+--- src/gui.cs.orig	Mon Feb 28 16:08:34 2005
++++ src/gui.cs	Sun Oct 23 17:31:17 2005
+@@ -541,8 +541,8 @@
+ 		private int update_queue_status(string queue)
+ 		{
+ 			G_ListView view;
+-			Fax.FaxQueue q;
+-			Fax.FaxRecQueue rq;
++			Fax.FaxQueue q = null;
++			Fax.FaxRecQueue rq = null;
+ 						
+ 			view = lv;
+ 				
diff --git a/comms/gfax/pkg-plist b/comms/gfax/pkg-plist
index 96da6968d085..a836edc99270 100644
--- a/comms/gfax/pkg-plist
+++ b/comms/gfax/pkg-plist
@@ -2,8 +2,8 @@ bin/gfax
 bin/gfaxlpr
 lib/gfax/gfax.exe
 share/gnome/applications/gfax.desktop
-share/gnome/libgnomeprint/2.10.3/models/GNOME-GFAX-PS.xml
-share/gnome/libgnomeprint/2.10.3/printers/GFAX.xml
+share/gnome/libgnomeprint/2.12.1/models/GNOME-GFAX-PS.xml
+share/gnome/libgnomeprint/2.12.1/printers/GFAX.xml
 share/gnome/pixmaps/gfax.png
 share/gnome/pixmaps/send.png
 @dirrm lib/gfax
-- 
cgit v1.2.3