From 23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d Mon Sep 17 00:00:00 2001
From: Alexander Leidinger <netchild@FreeBSD.org>
Date: Fri, 17 Jun 2005 22:59:29 +0000
Subject: Mega-patch to cleanup the ports infrastructure regarding our linux
 bits:   - USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use
 FreeBSD     tools to strip binaries anymore, so it's not neccesary anymore to
 override     STRIP and STRIP_CMD.   - USE_LINUX_PREFIX implies NO_MTREE now. 
  - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries  
   instead upon the native FreeBSD libraries.   - The variable LINUX_BASE_PORT
 contains a string which is suitable as an     item in *_DEPENDS, so if a port
 BATCH_DEPENDS or FETCH_DEPENDS upon the     default (or overriden) linux
 base, ${LINUX_BASE_PORT} should be used     instead of a hardcoded reference.
   - Change all ports to comply to the "new world order".   - The Ports
 Collection now allows to override the default linux_base port.     Specify
 e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use    
 ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use    
 ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}).   - If
 USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base    
 port and if USE_LINUX isn't set to "yes" (case insensitive), the port will   
  be marked as IGNORE. [1]   - Readd USE_LINUX knobs into several ports and
 make several uses of a     conditional dependency ("USE_LINUX?=") into an
 unconditional one     ("USE_LINUX=") which where removed/changed by Trevor to
 allow the use of     alternative linux_base ports. While this is a nice goal,
 the implementation     resulted in missing dependencies. The
 OVERRIDE_LINUX_BASE_PORT knob     in this commit is supposed to fix the
 problem while keeping the feature.     Basicaly this includes a backout of
 Trevor's commit, to prevent confusion     I mention it here explicitely.   -
 Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports.    
 Chase dependencies for this.   - Changes to make linux_devtools installable
 on amd64, remove some stray     device nodes (they don't work on recent OS
 versions and aren't really     needed).   - Make linux_base-8 PREFIX clean
 and remove some stray device nodes.     Additionally tell a little bit more
 about how to setup NIS/YP [2].   - Update the PGSQL dependency in the
 linux-opengroupware port to a recent     version (the old one isn't available
 anymore), I don't know if this     works (at least it isn't more broken than
 before).   - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the
 divx4linux     ports, the former path exists already and gets populated by
 other     packages too (PREFIX=LINUXPREFIX!).   - Fix some obvious
 (non-linuxolator) bugs in some linux ports while being     there.   - Bump
 PORTREVISION where neccesary.

Requested by:	portmgr (linimon) [1]
Submittted by:	Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2]
Approved by:	portmgr (kris, linimon), maintainers (or maintainer timeout)
Tested on:	ports cluster (kris)
Reviewed by:	silence on emulation@
Superseedes PR:	69997

Maintainer approval from:
	chris@chrisburkert.de
	cracauer@cons.org
	des
	girgen
	jamie@bishopston.net
	mezz
	mi
	nivit@users.sf.net
        pat
	simond@irrelevant.org
	riggs@rrr.de
	Udo.Schweigert@Siemens.com
---
 cad/linux-gid/Makefile | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

(limited to 'cad/linux-gid')

diff --git a/cad/linux-gid/Makefile b/cad/linux-gid/Makefile
index 441aadce2522..94d219d139e5 100644
--- a/cad/linux-gid/Makefile
+++ b/cad/linux-gid/Makefile
@@ -15,12 +15,11 @@ DISTNAME=	${PORTNAME}${PORTVERSION}
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	A graphical pre- and post-processor for numerical simulation programs
 
-RUN_DEPENDS=	${LINUXBASE}${X11BASE}/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs
-
 CONFLICTS=	id-utils-[0-9]* coreutils-[0-9]*
 ONLY_FOR_ARCHS=	amd64 i386
 
-USE_LINUX?=	yes
+USE_LINUX=	yes
+USE_X_PREFIX=	yes
 USE_REINPLACE=	yes
 REINPLACE_ARGS=	-i ""
 NO_WRKSUBDIR=	yes
-- 
cgit v1.2.3