summaryrefslogtreecommitdiff
path: root/x11/yelp
diff options
context:
space:
mode:
Diffstat (limited to 'x11/yelp')
-rw-r--r--x11/yelp/Makefile19
-rw-r--r--x11/yelp/distinfo5
-rw-r--r--x11/yelp/files/patch-libyelp_Makefile.am18
-rw-r--r--x11/yelp/files/patch-libyelp_yelp-man-parser.c2
-rw-r--r--x11/yelp/pkg-plist7
5 files changed, 15 insertions, 36 deletions
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index c9128554eceb..35f8a9039f56 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= yelp
-PORTVERSION= 3.18.1
-PORTREVISION= 1
+PORTVERSION= 3.22.0
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -16,20 +15,21 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= yelp-xsl>=0:textproc/yelp-xsl \
itstool:textproc/itstool
-LIB_DEPENDS= libwebkit2gtk-4.0.so:www/webkit2-gtk3
+LIB_DEPENDS= libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
+ libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error \
+ libsoup-2.4.so:devel/libsoup
RUN_DEPENDS= yelp-xsl>=0:textproc/yelp-xsl
PORTSCOUT= limitw:1,even
-USES= autoreconf desktop-file-utils gettext gmake gnome libtool pathfix \
- pkgconfig tar:xz
+USES= desktop-file-utils gettext gmake gnome libtool pathfix \
+ pkgconfig sqlite tar:xz
USE_XORG= x11 ice
-USE_GNOME= gtk30 intlhack libxml2 libxslt
+USE_GNOME= cairo gtk30 intlhack libxml2 libxslt
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.gnome.yelp.gschema.xml
INSTALL_TARGET= install-strip
@@ -41,7 +41,8 @@ CONFIGURE_ENV+= YELP_LZMA_CFLAGS="-I/usr/include" \
.endif
post-patch:
- @${CP} ${FILESDIR}/yelp-groff ${WRKSRC}/libyelp
+ @${REINPLACE_CMD} -e 's|%%LIBEXECDIR%%|${PREFIX}/libexec|g' \
+ ${WRKSRC}/libyelp/yelp-man-parser.c
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/yelp-groff ${STAGEDIR}${PREFIX}/libexec
diff --git a/x11/yelp/distinfo b/x11/yelp/distinfo
index 25b201115059..aceb45721869 100644
--- a/x11/yelp/distinfo
+++ b/x11/yelp/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gnome3/yelp-3.18.1.tar.xz) = ba3a4eb4717c0ecf4a2e40eff0963fcd12c700c4fb80b83ecaad8b7032256880
-SIZE (gnome3/yelp-3.18.1.tar.xz) = 1386044
+TIMESTAMP = 1479730974
+SHA256 (gnome3/yelp-3.22.0.tar.xz) = 8616b77c239aaa731312609f192c9b2c71d54b2cae42ff23efa23b5b3188778e
+SIZE (gnome3/yelp-3.22.0.tar.xz) = 1383500
diff --git a/x11/yelp/files/patch-libyelp_Makefile.am b/x11/yelp/files/patch-libyelp_Makefile.am
deleted file mode 100644
index 20d8e7f4ff33..000000000000
--- a/x11/yelp/files/patch-libyelp_Makefile.am
+++ /dev/null
@@ -1,18 +0,0 @@
---- libyelp/Makefile.am.orig 2016-07-10 15:09:03 UTC
-+++ libyelp/Makefile.am
-@@ -65,6 +65,7 @@ yelp-common-types.c: $(libyelpcommon_hea
- $(libyelpcommon_headers)) > $@
-
- lib_LTLIBRARIES = libyelp.la
-+libexec_SCRIPTS = yelp-groff
-
- libyelp_la_SOURCES = \
- yelp-bookmarks.c \
-@@ -115,6 +116,7 @@ libyelp_la_CFLAGS =
- $(YELP_CFLAGS) \
- -Wno-deprecated-declarations \
- -DDATADIR=\""$(datadir)"\" \
-+ -DLIBEXECDIR=\"$(libexecdir)\" \
- -DYELP_ICON_PATH=\"$(YELP_ICON_PATH)\"
-
- libyelp_la_CPPFLAGS = \
diff --git a/x11/yelp/files/patch-libyelp_yelp-man-parser.c b/x11/yelp/files/patch-libyelp_yelp-man-parser.c
index 0f2d63662c16..276f1372989e 100644
--- a/x11/yelp/files/patch-libyelp_yelp-man-parser.c
+++ b/x11/yelp/files/patch-libyelp_yelp-man-parser.c
@@ -5,7 +5,7 @@
gint ystdout;
GError *err = NULL;
- const gchar *argv[] = { "man", "-Z", "-Tutf8", "-EUTF-8", path, NULL };
-+ const gchar *argv[] = { LIBEXECDIR "/yelp-groff", path, NULL };
++ const gchar *argv[] = { "%%LIBEXECDIR%%", "/yelp-groff", path, NULL };
gchar **my_argv;
/* g_strdupv() should accept a "const gchar **". */
diff --git a/x11/yelp/pkg-plist b/x11/yelp/pkg-plist
index 725859e9a7ec..102e56e6449e 100644
--- a/x11/yelp/pkg-plist
+++ b/x11/yelp/pkg-plist
@@ -1,7 +1,6 @@
bin/gnome-help
bin/yelp
include/libyelp/yelp-bookmarks.h
-include/libyelp/yelp-common-types.h
include/libyelp/yelp-docbook-document.h
include/libyelp/yelp-document.h
include/libyelp/yelp-help-list.h
@@ -22,8 +21,6 @@ lib/libyelp.a
lib/libyelp.so
lib/libyelp.so.0
lib/libyelp.so.0.0.0
-lib/yelp/libyelpcommon.a
-lib/yelp/libyelpcommon.so
lib/yelp/web-extensions/libyelpwebextension.a
lib/yelp/web-extensions/libyelpwebextension.so
libexec/yelp-groff
@@ -38,7 +35,6 @@ share/gtk-doc/html/libyelp/ch01.html
share/gtk-doc/html/libyelp/ch01s02.html
share/gtk-doc/html/libyelp/home.png
share/gtk-doc/html/libyelp/index.html
-share/gtk-doc/html/libyelp/index.sgml
share/gtk-doc/html/libyelp/left-insensitive.png
share/gtk-doc/html/libyelp/left.png
share/gtk-doc/html/libyelp/libyelp-yelp-error.html
@@ -51,6 +47,7 @@ share/gtk-doc/html/libyelp/up-insensitive.png
share/gtk-doc/html/libyelp/up.png
share/locale/af/LC_MESSAGES/yelp.mo
share/locale/am/LC_MESSAGES/yelp.mo
+share/locale/an/LC_MESSAGES/yelp.mo
share/locale/ar/LC_MESSAGES/yelp.mo
share/locale/as/LC_MESSAGES/yelp.mo
share/locale/ast/LC_MESSAGES/yelp.mo
@@ -224,7 +221,6 @@ share/locale/zu/LC_MESSAGES/yelp.mo
%%DATADIR%%/mathjax/jax/element/mml/optable/GreekAndCoptic.js
%%DATADIR%%/mathjax/jax/element/mml/optable/Latin1Supplement.js
%%DATADIR%%/mathjax/jax/element/mml/optable/LetterlikeSymbols.js
-%%DATADIR%%/mathjax/jax/element/mml/optable/Makefile.am
%%DATADIR%%/mathjax/jax/element/mml/optable/MathOperators.js
%%DATADIR%%/mathjax/jax/element/mml/optable/MiscMathSymbolsA.js
%%DATADIR%%/mathjax/jax/element/mml/optable/MiscMathSymbolsB.js
@@ -265,7 +261,6 @@ share/locale/zu/LC_MESSAGES/yelp.mo
%%DATADIR%%/mathjax/jax/input/MathML/entities/y.js
%%DATADIR%%/mathjax/jax/input/MathML/entities/z.js
%%DATADIR%%/mathjax/jax/input/MathML/jax.js
-%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/Makefile.am
%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/annotation-xml.js
%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/maction.js
%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/menclose.js