summaryrefslogtreecommitdiff
path: root/x11/accessx
diff options
context:
space:
mode:
Diffstat (limited to 'x11/accessx')
-rw-r--r--x11/accessx/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/x11/accessx/Makefile b/x11/accessx/Makefile
index 52b8a1211a66..4f48d50a0851 100644
--- a/x11/accessx/Makefile
+++ b/x11/accessx/Makefile
@@ -20,8 +20,11 @@ WRKSRC= ${WRKDIR}/accessx
USE_REINPLACE= yes
USE_X_PREFIX= yes
-pre-build:
- ${REINPLACE_CMD} -e "s@g\+\+@${CXX} ${CXXFLAGS} -I${X11BASE}/include@g" ${WRKSRC}/Makefile
+post-patch:
+ ${REINPLACE_CMD} \
+ -e "s@/usr/local@${PREFIX}@" \
+ -e "s@g\+\+@${CXX} ${CXXFLAGS} -I${X11BASE}/include@g" \
+ ${WRKSRC}/Makefile
${REINPLACE_CMD} -e "s@wish -f@wish8.2 -f@g" ${WRKSRC}/accessx
post-install: