summaryrefslogtreecommitdiff
path: root/x11-wm/windowmaker/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/windowmaker/Makefile')
-rw-r--r--x11-wm/windowmaker/Makefile43
1 files changed, 25 insertions, 18 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 5cb1d7077455..223efa546197 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -6,13 +6,16 @@
#
PORTNAME= windowmaker
-PORTVERSION= 0.62.1
+PORTVERSION= 0.63.1
CATEGORIES= x11-wm windowmaker
MASTER_SITES= ${MASTER_SITE_WINDOWMAKER} \
- http://jgo.local.net/cool_downloads/wm/
+ http://jgo.local.net/cool_downloads/wm/ \
+ ${MASTER_SITE_LOCAL:S,%SUBDIR%,sobomax,g}
MASTER_SITE_SUBDIR= beta/srcs
DISTNAME= WindowMaker-${PORTVERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DATAFILES}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ libwmfun-${PORTVERSION}${EXTRACT_SUFX} \
+ ${DATAFILES}
MAINTAINER= sobomax@FreeBSD.org
@@ -21,7 +24,8 @@ LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
PropList.2:${PORTSDIR}/devel/libPropList \
- intl.1:${PORTSDIR}/devel/gettext
+ intl.1:${PORTSDIR}/devel/gettext \
+ freetype.6:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
USE_PERL5= yes
@@ -30,23 +34,26 @@ USE_XPM= yes
WANT_GNOME= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= X11BASE=${X11BASE} LIBS=-L${LOCALBASE}/lib \
- CPPFLAGS=-I${LOCALBASE}/include \
- LINGUAS="cs da de el es fi fr gl hr it ja ko nl no pl pt ro ru se sk tr zh_CN zh_TW.Big5"
+CONFIGURE_ENV= X11BASE=${X11BASE} \
+ LIBS=-L${LOCALBASE}/lib \
+ CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2" \
+ LINGUAS="${LINGUAS}"
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
- --with-nlsdir=${PREFIX}/share/locale \
- --with-libs-from="-L${LOCALBASE}/lib" \
- --with-incs-from="-I${LOCALBASE}/include" \
- --with-appspath="${PREFIX}/GNUstep/Apps" \
- --disable-debug
+ --with-nlsdir=${PREFIX}/share/locale \
+ --with-libs-from="-L${LOCALBASE}/lib" \
+ --with-incs-from="-I${LOCALBASE}/include" \
+ --with-appspath="${PREFIX}/GNUstep/Apps" \
+ --disable-debug
-MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x \
- wdwrite.1x wmaker.1x wmsetbg.1x wsetfont.1x wxcopy.1x wxpaste.1x
+MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x wdwrite.1x \
+ wmaker.1x wmsetbg.1x wsetfont.1x wxcopy.1x wxpaste.1x
DATAFILES= WindowMaker-extra-0.1.tar.bz2
.include <bsd.port.pre.mk>
+LINGUAS!= /bin/cat ${FILESDIR}/LINGUAS
+
.if defined(HAVE_GNOME)
CONFIGURE_ARGS+= --enable-gnome
.endif
@@ -63,10 +70,6 @@ pre-extract:
CONFIGURE_ARGS+= --enable-single-icon
.endif
-post-extract:
- @cd ${WRKSRC} && \
- ${TAR} xfz libwmfun-0.0.3.tar.gz
-
post-patch:
@perl -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/WPrefs.app/Paths.c \
${WRKSRC}/WindowMaker/Defaults/*
@@ -80,4 +83,8 @@ post-install:
${MAKE} ${MAKE_ARGS} ${INSTALL_TARGET}
${MKDIR} ${PREFIX}/share/WindowMaker/Sounds
+update-LINGUAS: extract
+ cd ${WRKSRC}/po && \
+ ${ECHO} *.po | ${SED} 's|\.po||g' > ${FILESDIR}/LINGUAS
+
.include <bsd.port.post.mk>