summaryrefslogtreecommitdiff
path: root/x11-wm/hackedbox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--x11-wm/hackedbox/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-wm/hackedbox/Makefile b/x11-wm/hackedbox/Makefile
index d4d9e7e6b9b4..86fde9e9091e 100644
--- a/x11-wm/hackedbox/Makefile
+++ b/x11-wm/hackedbox/Makefile
@@ -28,6 +28,12 @@ USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-bg-utils
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
+.endif
+
do-patch:
${REINPLACE_CMD} -e \
"s:/usr/local/share/hackedbox:${PREFIX}/share/hackedbox:g" \
@@ -91,4 +97,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>