summaryrefslogtreecommitdiff
path: root/x11-toolkits/ruby-pango/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/ruby-pango/Makefile')
-rw-r--r--x11-toolkits/ruby-pango/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-toolkits/ruby-pango/Makefile b/x11-toolkits/ruby-pango/Makefile
index a2187ac8a451..783697e8fa7d 100644
--- a/x11-toolkits/ruby-pango/Makefile
+++ b/x11-toolkits/ruby-pango/Makefile
@@ -20,8 +20,8 @@ COMMENT= Ruby binding for Pango
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
USE_RUBY= yes
-USE_XLIB= yes
USE_GNOME= pango
+USE_REINPLACE= yes
USE_RUBY_EXTCONF= yes
.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
@@ -31,6 +31,11 @@ INSTALL_TARGET= site-install
DOCS= COPYING.LIB ChangeLog README
+post-patch:
+ @${REINPLACE_CMD} -e 's|local/bin/ruby|bin/env ruby|g' \
+ ${WRKSRC}/sample/*.rb
+ @${FIND} ${WRKSRC} -name '*.bak' -delete
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${RUBY_MODEXAMPLESDIR}