summaryrefslogtreecommitdiff
path: root/x11-toolkits/ruby-panelapplet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/ruby-panelapplet/Makefile')
-rw-r--r--x11-toolkits/ruby-panelapplet/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11-toolkits/ruby-panelapplet/Makefile b/x11-toolkits/ruby-panelapplet/Makefile
index de768d7f572a..f9358f9a7a8d 100644
--- a/x11-toolkits/ruby-panelapplet/Makefile
+++ b/x11-toolkits/ruby-panelapplet/Makefile
@@ -17,10 +17,11 @@ DIST_SUBDIR= ruby
MAINTAINER= mezz@FreeBSD.org
COMMENT= Ruby binding for libpanel-applet
-RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gnome2.so:${PORTSDIR}/x11/ruby-gnome2
USE_RUBY= yes
USE_GNOME= gnomepanel
+USE_REINPLACE= yes
USE_RUBY_EXTCONF= yes
.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
@@ -30,6 +31,14 @@ INSTALL_TARGET= site-install
DOCS= COPYING.LIB ChangeLog README
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/lib/|${X11BASE}/libdata/|g ; \
+ s|/usr/libexec/|${X11BASE}/libexec/|g' \
+ ${WRKSRC}/sample/README ${WRKSRC}/sample/*.server
+ @${REINPLACE_CMD} -e 's|bin/ruby|bin/env ruby|g' \
+ ${WRKSRC}/sample/hello-applet.rb
+ @${FIND} ${WRKSRC} -name '*.bak' -delete
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${RUBY_MODEXAMPLESDIR}