summaryrefslogtreecommitdiff
path: root/x11-toolkits/hs-OpenGLRaw
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/hs-OpenGLRaw')
-rw-r--r--x11-toolkits/hs-OpenGLRaw/Makefile15
-rw-r--r--x11-toolkits/hs-OpenGLRaw/distinfo2
-rw-r--r--x11-toolkits/hs-OpenGLRaw/pkg-descr17
3 files changed, 34 insertions, 0 deletions
diff --git a/x11-toolkits/hs-OpenGLRaw/Makefile b/x11-toolkits/hs-OpenGLRaw/Makefile
new file mode 100644
index 000000000000..186d31c653d1
--- /dev/null
+++ b/x11-toolkits/hs-OpenGLRaw/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= OpenGLRaw
+PORTVERSION= 1.3.0.0
+CATEGORIES= x11-toolkits haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Raw binding for the OpenGL graphics system
+
+LICENSE= BSD
+
+USE_GL= gl glut
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/x11-toolkits/hs-OpenGLRaw/distinfo b/x11-toolkits/hs-OpenGLRaw/distinfo
new file mode 100644
index 000000000000..a170675a30fc
--- /dev/null
+++ b/x11-toolkits/hs-OpenGLRaw/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/OpenGLRaw-1.3.0.0.tar.gz) = 6228ca9ac967350fcb6abac25b8027660ad8599914a60ef0fd10919a6d2cd745
+SIZE (cabal/OpenGLRaw-1.3.0.0.tar.gz) = 75328
diff --git a/x11-toolkits/hs-OpenGLRaw/pkg-descr b/x11-toolkits/hs-OpenGLRaw/pkg-descr
new file mode 100644
index 000000000000..4c9981fb3664
--- /dev/null
+++ b/x11-toolkits/hs-OpenGLRaw/pkg-descr
@@ -0,0 +1,17 @@
+OpenGLRaw is a raw Haskell binding for the OpenGL 3.2 graphics system
+and lots of OpenGL extensions. It is basically a 1:1 mapping of
+OpenGL's C API, intended as a basis for a nicer interface. OpenGLRaw
+offers access to all necessary functions, tokens and types plus a
+general facility for loading extension entries. The module hierarchy
+closely mirrors the naming structure of the OpenGL extensions, making it
+easy to find the right module to import. All API entries are loaded
+dynamically, so no special C header files are needed for building this
+package. If an API entry is not found at runtime, a userError is
+thrown.
+
+OpenGL is the industry's most widely used and supported 2D and 3D
+graphics application programming interface (API), incorporating a broad
+set of rendering, texture mapping, special effects, and other powerful
+visualization functions.
+
+WWW: http://www.haskell.org/haskellwiki/Opengl