summaryrefslogtreecommitdiff
path: root/www/www6to4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/www6to4/Makefile')
-rw-r--r--www/www6to4/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/www/www6to4/Makefile b/www/www6to4/Makefile
new file mode 100644
index 000000000000..f8f5b7006606
--- /dev/null
+++ b/www/www6to4/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: www6to4
+# Date created: 22.03.2002
+# Whom: Janos Mohacsi <janos.mohacsi@dante.org.uk>
+#
+# $FreeBSD$
+
+PORTNAME= www6to4
+PORTVERSION= 1.5
+CATEGORIES= www ipv6
+MASTER_SITES= ftp://ftp.pasta.cs.uit.no/pub/Vermicelli/
+
+MAINTAINER= Janos.Mohacsi@dante.org.uk
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/www6to4 ${PREFIX}/sbin
+ @if [ ! -d ${PREFIX}/etc/www6to4 ]; then \
+ ${MKDIR} ${PREFIX}/etc/www6to4; fi
+ ${INSTALL_DATA} ${WRKSRC}/www6to4.conf \
+ ${PREFIX}/etc/www6to4/www6to4.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/www6to4_forward.conf \
+ ${PREFIX}/etc/www6to4/www6to4_forward.conf.sample
+.if !defined(NOPORTDOCS)
+ if [ ! -d ${DOCSDIR} ]; then \
+ ${MKDIR} ${DOCSDIR}; fi
+ ${INSTALL_DATA} ${WRKSRC}/README \
+ ${DOCSDIR}
+.endif
+ @if [ ! -f ${PREFIX}/etc/rc.d/www6to4.sh ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/www6to4.sh startup file."; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/www6to4.sh ${PREFIX}/etc/rc.d/www6to4.sh; \
+ fi
+
+.include <bsd.port.mk>