summaryrefslogtreecommitdiff
path: root/www/rt2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--www/rt2/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/www/rt2/Makefile b/www/rt2/Makefile
index e6666738a1f4..51125eca4449 100644
--- a/www/rt2/Makefile
+++ b/www/rt2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rt2
PORTVERSION= 2.0.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.fsck.com/pub/rt/release/
DISTNAME= rt-${PORTVERSION:S/./-/g}
@@ -16,6 +16,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= RT is an industrial-grade ticketing system written in Perl
BUILD_DEPENDS= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/${PERL_ARCH}/Apache/Cookie.pm:${PORTSDIR}/www/p5-libapreq \
${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI \
${SITE_PERL}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session \
@@ -157,11 +159,4 @@ post-install:
BROKEN= "Broken pkg-plist"
.endif
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
-.endif
-
.include <bsd.port.post.mk>