summaryrefslogtreecommitdiff
path: root/www/quanta/files
diff options
context:
space:
mode:
Diffstat (limited to 'www/quanta/files')
-rw-r--r--www/quanta/files/patch-Makefile.in24
-rw-r--r--www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::DbgSite.h10
-rw-r--r--www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ListenerBase.cpp18
-rw-r--r--www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ListenerGlobals.cpp19
-rw-r--r--www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ThreadBase.cpp10
-rw-r--r--www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::dbg_core.c13
-rw-r--r--www/quanta/files/patch-quanta::plugins::php4dgb::debugger.h10
-rw-r--r--www/quanta/files/patch-quanta::plugins::php4dgb::listener.cpp8
8 files changed, 112 insertions, 0 deletions
diff --git a/www/quanta/files/patch-Makefile.in b/www/quanta/files/patch-Makefile.in
new file mode 100644
index 000000000000..9b25189c91c4
--- /dev/null
+++ b/www/quanta/files/patch-Makefile.in
@@ -0,0 +1,24 @@
+--- Makefile.in.orig Wed Dec 5 11:04:46 2001
++++ Makefile.in Thu Jan 24 16:34:24 2002
+@@ -251,17 +251,14 @@
+ cd $(top_srcdir) && $(AUTOMAKE) --gnu ./Makefile
+ cd $(top_srcdir) && perl admin/am_edit Makefile.in
+
+-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status $(BUILT_SOURCES)
+- cd $(top_builddir) \
+- && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
++Makefile:
++ ${ECHO} ""
+
+ $(ACLOCAL_M4): configure.in acinclude.m4
+ cd $(srcdir) && $(ACLOCAL)
+
+-config.status: $(srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
+- $(SHELL) ./config.status --recheck
+-$(srcdir)/configure: $(srcdir)/configure.in $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
+- cd $(srcdir) && $(AUTOCONF)
++config.status:
++ @{ECHO} config.status patched
+
+ config.h: stamp-h
+ @if test ! -f $@; then \
diff --git a/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::DbgSite.h b/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::DbgSite.h
new file mode 100644
index 000000000000..521a0cb8d7c3
--- /dev/null
+++ b/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::DbgSite.h
@@ -0,0 +1,10 @@
+--- quanta/plugins/php4dbg/dbgbase/DbgSite.h.orig Thu Jan 24 17:01:33 2002
++++ quanta/plugins/php4dbg/dbgbase/DbgSite.h Thu Jan 24 17:01:48 2002
+@@ -14,6 +14,7 @@
+ #ifndef _DBGSITE_H_
+ #define _DBGSITE_H_
+
++#include <sys/types.h>
+ #include <qobject.h>
+ #include "ListenerGlobals.h"
+ #include "RequestorBase.h"
diff --git a/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ListenerBase.cpp b/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ListenerBase.cpp
new file mode 100644
index 000000000000..7a69baa79f2c
--- /dev/null
+++ b/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ListenerBase.cpp
@@ -0,0 +1,18 @@
+--- quanta/plugins/php4dbg/dbgbase/ListenerBase.cpp.orig Thu Jan 24 17:09:23 2002
++++ quanta/plugins/php4dbg/dbgbase/ListenerBase.cpp Thu Jan 24 17:09:52 2002
+@@ -11,11 +11,13 @@
+ the world-wide-web at http://dd.cron.ru/license
+ ***************************************************************************/
+
++#include <sys/types.h>
++#include <stdio.h>
++#include <assert.h>
+ #include "dbg_core.h"
+ #include "ListenerBase.h"
+ #include "ThreadBase.h"
+-#include <stdio.h>
+-#include <assert.h>
++
+
+ ListenerBase::~ListenerBase() {
+ DBGTRACE("ListenerBase::~ListenerBase\n");
diff --git a/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ListenerGlobals.cpp b/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ListenerGlobals.cpp
new file mode 100644
index 000000000000..efa09025f5c1
--- /dev/null
+++ b/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ListenerGlobals.cpp
@@ -0,0 +1,19 @@
+--- quanta/plugins/php4dbg/dbgbase/ListenerGlobals.cpp.orig Thu Jan 24 16:50:10 2002
++++ quanta/plugins/php4dbg/dbgbase/ListenerGlobals.cpp Thu Jan 24 16:51:58 2002
+@@ -11,6 +11,7 @@
+ the world-wide-web at http://dd.cron.ru/license
+ ***************************************************************************/
+
++#include <sys/types.h>
+ #include <stdarg.h>
+ #include <stdio.h>
+ #include "ListenerGlobals.h"
+@@ -344,7 +345,7 @@
+ ret_val = select(listen_socket + 1, &rset, NULL, NULL, &timeout);
+ if (ret_val>0) {
+ siz = sizeof(laddr);
+- ret_val = accept(listen_socket, &laddr, &siz);
++ ret_val = accept(listen_socket, &laddr,(socklen_t *) &siz);
+ }
+ if (ret_val <= 0) {
+ return (ret_val) ? (-1) : (0);
diff --git a/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ThreadBase.cpp b/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ThreadBase.cpp
new file mode 100644
index 000000000000..3f2e2818e985
--- /dev/null
+++ b/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::ThreadBase.cpp
@@ -0,0 +1,10 @@
+--- quanta/plugins/php4dbg/dbgbase/ThreadBase.cpp.orig Thu Jan 24 16:52:35 2002
++++ quanta/plugins/php4dbg/dbgbase/ThreadBase.cpp Thu Jan 24 16:52:44 2002
+@@ -11,6 +11,7 @@
+ the world-wide-web at http://dd.cron.ru/license
+ ***************************************************************************/
+
++#include <sys/types.h>
+ #include "ThreadBase.h"
+ #include "ListenerGlobals.h"
+ #include "dbg_core.h"
diff --git a/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::dbg_core.c b/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::dbg_core.c
new file mode 100644
index 000000000000..669c0a7caaf3
--- /dev/null
+++ b/www/quanta/files/patch-quanta::plugins::php4dgb::dbgbase::dbg_core.c
@@ -0,0 +1,13 @@
+--- quanta/plugins/php4dbg/dbgbase/dbg_core.c.orig Thu Jan 24 16:53:35 2002
++++ quanta/plugins/php4dbg/dbgbase/dbg_core.c Thu Jan 24 16:53:42 2002
+@@ -11,9 +11,9 @@
+ the world-wide-web at http://dd.cron.ru/license
+ ***************************************************************************/
+
++#include <sys/types.h>
+ #include "dbg_core.h"
+ #include <string.h>
+-#include <malloc.h>
+ #include <stdlib.h>
+
+ #ifdef DBG_USE_STDALLOCA
diff --git a/www/quanta/files/patch-quanta::plugins::php4dgb::debugger.h b/www/quanta/files/patch-quanta::plugins::php4dgb::debugger.h
new file mode 100644
index 000000000000..8f4c3c346202
--- /dev/null
+++ b/www/quanta/files/patch-quanta::plugins::php4dgb::debugger.h
@@ -0,0 +1,10 @@
+--- quanta/plugins/php4dbg/debugger.h.orig Thu Jan 24 17:22:31 2002
++++ quanta/plugins/php4dbg/debugger.h Thu Jan 24 17:22:47 2002
+@@ -6,6 +6,7 @@
+ #endif
+
+ #include <qobject.h>
++#include <sys/types.h>
+
+ class Listener;
+ class QSocketNotifier;
diff --git a/www/quanta/files/patch-quanta::plugins::php4dgb::listener.cpp b/www/quanta/files/patch-quanta::plugins::php4dgb::listener.cpp
new file mode 100644
index 000000000000..4b16cefbb9d1
--- /dev/null
+++ b/www/quanta/files/patch-quanta::plugins::php4dgb::listener.cpp
@@ -0,0 +1,8 @@
+--- quanta/plugins/php4dbg/listener.cpp.orig Thu Jan 24 17:27:25 2002
++++ quanta/plugins/php4dbg/listener.cpp Thu Jan 24 17:27:41 2002
+@@ -1,4 +1,4 @@
+-
++#include <sys/types.h>
+ #include "listener.h"
+
+ #include <stdarg.h>