summaryrefslogtreecommitdiff
path: root/www/p5-URI-Fetch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-URI-Fetch/Makefile')
-rw-r--r--www/p5-URI-Fetch/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/www/p5-URI-Fetch/Makefile b/www/p5-URI-Fetch/Makefile
index 3c84729e8efb..de11a0fb5184 100644
--- a/www/p5-URI-Fetch/Makefile
+++ b/www/p5-URI-Fetch/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= URI-Fetch
-PORTVERSION= 0.04
+PORTVERSION= 0.05
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= URI
@@ -21,6 +21,21 @@ BUILD_DEPENDS= ${SITE_PERL}/Class/ErrorHandler.pm:${PORTSDIR}/devel/p5-Class-Err
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
RUN_DEPENDS= ${BUILD_DEPENDS}
+OPTIONS= ZLIB "GZIP Support" on \
+ CACHE "Caching Support" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_ZLIB)
+BUILD_DEPENDS+= p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib
+RUN_DEPENDS+= p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib
+.endif
+
+.if defined(WITH_CACHE)
+BUILD_DEPENDS+= p5-Cache>=0:${PORTSDIR}/devel/p5-Cache
+RUN_DEPENDS+= p5-Cache>=0:${PORTSDIR}/devel/p5-Cache
+.endif
+
PERL_MODBUILD= yes
MAN3= URI::Fetch.3 \
@@ -29,7 +44,6 @@ MAN3= URI::Fetch.3 \
post-patch:
${PERL} -pi -e '$$_ = "" if m|auto_install|' ${WRKSRC}/Makefile.PL
-.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
IGNORE= requires Perl 5.6 or later. Please install lang/perl5 or lang/perl5.8 and try again
.endif