summaryrefslogtreecommitdiff
path: root/www/p5-HTML-Embperl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-HTML-Embperl/Makefile')
-rw-r--r--www/p5-HTML-Embperl/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/www/p5-HTML-Embperl/Makefile b/www/p5-HTML-Embperl/Makefile
index a4cb1db3a817..a8bbab797a30 100644
--- a/www/p5-HTML-Embperl/Makefile
+++ b/www/p5-HTML-Embperl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= HTML-Embperl
-PORTVERSION= 1.3.0
+PORTVERSION= 1.3.3
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML
@@ -14,12 +14,24 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kapr@crosswinds.net
+.if !defined(WITHOUT_APACHE)
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session
+.endif
PERL_CONFIGURE= yes
-IS_INTERACTIVE= yes
+.if !defined(WITHOUT_APACHE)
+CONFIGURE_ARGS= DEFINE=-DAPACHE INC=-I${LOCALBASE}/include/apache
+.endif
+INSTALL_TARGET= pure_install
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= HTML::Embperl.3 HTML::EmbperlD.3 HTML::EmbperlObject.3
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN1= embpexec.pl.1
+
+pre-configure:
+ ${CP} -f ${FILESDIR}/Makefile.PL ${WRKSRC}
.include <bsd.port.mk>