summaryrefslogtreecommitdiff
path: root/www/nspostgres/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/nspostgres/Makefile')
-rw-r--r--www/nspostgres/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/nspostgres/Makefile b/www/nspostgres/Makefile
new file mode 100644
index 000000000000..fb33424099df
--- /dev/null
+++ b/www/nspostgres/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: nspostgres
+# Date created: 30 January 2001
+# Whom: jkoshy
+#
+# $FreeBSD$
+#
+
+PORTNAME= nspostgres
+PORTVERSION= 3.0
+CATEGORIES= www databases
+MASTER_SITES= ftp://ftp.aolserver.com/modules/nspostgres/
+DISTNAME= nspostgres3_0
+
+MAINTAINER= jkoshy@freebsd.org
+
+RUN_DEPENDS= ${LOCALBASE}/aolserver/bin/nsd:${PORTSDIR}/www/aolserver \
+ ${LOCALBASE}/pgsql/bin/postmaster:${PORTSDIR}/databases/postgresql7
+
+WRKSRC= ${WRKDIR}/nspostgres
+
+USE_GMAKE= yes
+MAKE_ENV+= POSTGRES=${PREFIX}/pgsql BUILDPREFIX=${PREFIX}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nspostgres.so ${PREFIX}/aolserver/bin
+
+.include <bsd.port.mk>