summaryrefslogtreecommitdiff
path: root/www/mod_sqlinclude/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_sqlinclude/Makefile')
-rw-r--r--www/mod_sqlinclude/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/mod_sqlinclude/Makefile b/www/mod_sqlinclude/Makefile
new file mode 100644
index 000000000000..0c388212eed7
--- /dev/null
+++ b/www/mod_sqlinclude/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mod_sqlinclude
+# Date created: October 25 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+
+PORTNAME= mod_sqlinclude
+PORTVERSION= 1.2
+CATEGORIES= www
+MASTER_SITES= http://wfmh.org.pl/~carlos/files/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= anders@fix.no
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+APXS?= ${LOCALBASE}/sbin/apxs
+DOCS= CHANGES.txt README.txt TODO.txt
+
+do-build:
+ (cd ${WRKSRC} && ${APXS} -c -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib/mysql -lmysqlclient mod_sqlinclude.c)
+
+do-install:
+ (cd ${WRKSRC} && ${APXS} -i -A -n 'sqlinclude' mod_sqlinclude.so)
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>