summaryrefslogtreecommitdiff
path: root/www/mod_auth_mysql_another/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_auth_mysql_another/Makefile')
-rw-r--r--www/mod_auth_mysql_another/Makefile26
1 files changed, 22 insertions, 4 deletions
diff --git a/www/mod_auth_mysql_another/Makefile b/www/mod_auth_mysql_another/Makefile
index 17cdb3800ba5..7ae4d9c28e46 100644
--- a/www/mod_auth_mysql_another/Makefile
+++ b/www/mod_auth_mysql_another/Makefile
@@ -6,6 +6,7 @@
PORTNAME= mod_auth_mysql
PORTVERSION= 3.0.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/_//g}
@@ -15,16 +16,34 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Allows users to use MySQL databases for user authentication
USE_MYSQL= YES
+USE_REINPLACE= YES
-SHORTMODNAME= mysql_auth
-AP_FAST_BUILD= YES
-AP_GENPLIST= YES
+SHORTMODNAME= mysql_auth
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
AP_INC= ${LOCALBASE}/include/mysql
AP_LIB= ${LOCALBASE}/lib/mysql
+.if defined(WITH_APACHE2)
+AP_EXTRAS= -lmysqlclient -lz -lm
+USE_APACHE= 20+
+.else
+USE_APACHE= 13+
AP_EXTRAS= -DAPACHE${AP_VER} -lmysqlclient -lz -lm
+.endif
.include <bsd.port.pre.mk>
+.if defined(WITH_APACHE2)
+post-patch:
+ ${REINPLACE_CMD} -e "s|APR_XtOffsetOf|APR_OFFSETOF|g" \
+ -e "s|APR_XtOffset|APR_OFFSET|g" ${WRKSRC}/mod_auth_mysql.c
+.else
+pre-build:
+ ${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s|%%APXS%%|${APXS}|g" \
+ -e "s|%%AP_INC%%|${AP_INC}|g" -e "s|%%AP_LIB%%|${AP_LIB}|g" ${WRKSRC}/Makefile
+.endif
+
.if !defined(NOPORTDOCS)
post-build:
@${ECHO} "%%PORTDOCS%%%%DOCSDIR%%/CONFIGURE" >> ${PLIST}
@@ -37,5 +56,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}
.endif
-.include "${PORTSDIR}/www/apache20/Makefile.modules.3rd"
.include <bsd.port.post.mk>