summaryrefslogtreecommitdiff
path: root/www/mnogosearch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mnogosearch/Makefile')
-rw-r--r--www/mnogosearch/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index 096310588ece..78827749c95b 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -21,10 +21,13 @@ INSTALLS_SHLIB= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared \
- --enable-charset-guesser \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+.if defined(WITH_MNOGO_GUESSER)
+CONFIGURE_ARGS+= --enable-charset-guesser
+.endif
+
.if defined(WITH_MNOGO_PGSQL)
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}/pgsql