summaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/sdif/Makefile38
-rw-r--r--textproc/sdif/distinfo3
-rw-r--r--textproc/sdif/pkg-descr13
4 files changed, 55 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4178161e195f..40345a543558 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1593,6 +1593,7 @@
SUBDIR += scss
SUBDIR += sdcv
SUBDIR += sdf
+ SUBDIR += sdif
SUBDIR += sdocbook-xml
SUBDIR += sdom
SUBDIR += senna
diff --git a/textproc/sdif/Makefile b/textproc/sdif/Makefile
new file mode 100644
index 000000000000..752535d10a50
--- /dev/null
+++ b/textproc/sdif/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= sdif
+PORTVERSION= 2.8.20170401
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Side-by-side diff viewer for ANSI terminal
+
+LICENSE= GREPLE
+LICENSE_NAME= GREPLE License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+RUN_DEPENDS= ${SITE_PERL}/Getopt/EX.pm:devel/p5-Getopt-EX
+
+USES= perl5 shebangfix
+SHEBANG_FILES= ${PORTNAME}
+USE_GITHUB= yes
+GH_ACCOUNT= kaz-utashiro
+GH_TAGNAME= 356575d
+NO_BUILD= yes
+NO_ARCH= yes
+PLIST_FILES= bin/sdif \
+ %%SITE_PERL%%/App/sdif/colors.pm \
+ %%SITE_PERL%%/App/sdif/osx_autocolor.pm
+
+post-extract:
+ cd ${WRKSRC} && \
+ ${SED} -n "/^## Copyright/,/^$$/p" sdif > LICENSE
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ cd ${WRKSRC}/lib && \
+ ${COPYTREE_SHARE} App ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
+
+.include <bsd.port.mk>
diff --git a/textproc/sdif/distinfo b/textproc/sdif/distinfo
new file mode 100644
index 000000000000..25ea15d30271
--- /dev/null
+++ b/textproc/sdif/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1491037017
+SHA256 (kaz-utashiro-sdif-v2.8.20170401-356575d_GH0.tar.gz) = e2ee2814f585dccc9b90e5b76fc55cf5b6edace91043831e3a839ead5856fdb2
+SIZE (kaz-utashiro-sdif-v2.8.20170401-356575d_GH0.tar.gz) = 16067
diff --git a/textproc/sdif/pkg-descr b/textproc/sdif/pkg-descr
new file mode 100644
index 000000000000..2505d35bb6ab
--- /dev/null
+++ b/textproc/sdif/pkg-descr
@@ -0,0 +1,13 @@
+sdif is inspired by System V sdiff(1) command. The basic feature of
+sdif is making a side-by-side listing of two different files. All
+contents of two files are listed on left and right sides. Center
+column is used to indicate how different those lines. No mark means
+no difference. Added, deleted and modified lines are marked with `-'
+and `+' character.
+
+It also reads and formats the output from diff command from standard
+input. Besides normal diff output, context diff -c and unified diff
+-u output will be handled properly. Combined diff format is also
+supported, but currently limited upto three files.
+
+WWW: https://github.com/kaz-utashiro/sdif