summaryrefslogtreecommitdiff
path: root/textproc/py-qt4-xml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-qt4-xml/Makefile')
-rw-r--r--textproc/py-qt4-xml/Makefile72
1 files changed, 72 insertions, 0 deletions
diff --git a/textproc/py-qt4-xml/Makefile b/textproc/py-qt4-xml/Makefile
new file mode 100644
index 000000000000..e47d4e5ac119
--- /dev/null
+++ b/textproc/py-qt4-xml/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: py-qt4-xml
+# Date created: 2007-02-20
+# Whom: Danny Pansters <danny@ricin.com>
+#
+# $FreeBSD$
+
+PORTNAME= xml
+PORTVERSION= 20070318
+CATEGORIES= textproc devel python
+MASTER_SITES= http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt4/ \
+ http://freebsd.ricin.com/ports/distfiles/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
+DISTNAME= PyQt-x11-gpl-4-snapshot-${PORTVERSION}
+
+MAINTAINER= danny@ricin.com
+COMMENT= Python bindings for the Qt4 toolkit, QtXml module
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+HAS_CONFIGURE= yes
+USE_PYTHON= 2.3+
+USE_QT_VER= 4
+QT_COMPONENTS= xml qmake
+
+OPTIONS= API "Install QtXml API for QScintilla2" on \
+ DEBUG "Enable debugging in generated code" off \
+ SIPFILES "Install the QtXml SIP files" on \
+ TRACING "Enable tracing in generated code" off
+
+OPTIONSFILE= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
+APIFILE= ${QT_PREFIX}/share/qt4/qsci/api/python/QtXml.api
+SIPDIR= ${PREFIX}/share/py-sip
+ARGS= -b ${PREFIX}/bin -c -j 2 -d ${PYTHONPREFIX_SITELIBDIR}/PyQt4 \
+ -q ${QT_PREFIX}/bin/qmake-qt4 -a
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+ARGS+= -u
+.endif
+.if defined(WITHOUT_API)
+PLIST_SUB+= API="@comment "
+PLIST_SUB+= APIFILE="@comment "
+.else
+LIB_DEPENDS+= qscintilla2:${PORTSDIR}/devel/qscintilla2
+PLIST_SUB+= API=""
+PLIST_SUB+= APIFILE="share/qt4/qsci/api/python/QtXml.api"
+.endif
+.if defined(WITHOUT_SIPFILES)
+ARGS+= -v /dev/null
+PLIST_SUB+= SIPFILES="@comment "
+PLIST_SUB+= SIPDIR="@comment "
+.else
+ARGS+= -v ${SIPDIR}
+PLIST_SUB+= SIPFILES=""
+PLIST_SUB+= SIPDIR="share/py-sip"
+.endif
+.if defined(WITH_TRACING)
+ARGS+= -r
+.endif
+
+do-configure:
+ ( cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${PYTHON_CMD} configure.py ${ARGS} )
+
+post-install:
+.if defined(WITHOUT_API)
+ ( ${RM} ${APIFILE} )
+.endif
+
+.include <bsd.port.post.mk>