summaryrefslogtreecommitdiff
path: root/textproc/pdfoutline
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/pdfoutline')
-rw-r--r--textproc/pdfoutline/Makefile33
-rw-r--r--textproc/pdfoutline/distinfo3
-rw-r--r--textproc/pdfoutline/pkg-descr7
3 files changed, 43 insertions, 0 deletions
diff --git a/textproc/pdfoutline/Makefile b/textproc/pdfoutline/Makefile
new file mode 100644
index 000000000000..6b39943c50d5
--- /dev/null
+++ b/textproc/pdfoutline/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: pdfoutline
+# Date created: 4 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdfoutline
+PORTVERSION= 0.0.${DATE:S/-//g}
+DISTVERSION= 2.4
+CATEGORIES= textproc
+MASTER_SITES= SF/fntsample
+DISTNAME= fntsample-${DISTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Add outlines to PDF files
+
+RUN_DEPENDS= p5-PDF-API2>=0:${PORTSDIR}/textproc/p5-PDF-API2
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+DATE= 2007-03-14
+
+post-patch:
+ @${SED} -e 's|@DATE@|2007-03-14|' ${WRKSRC}/${PORTNAME}.1.in > ${WRKSRC}/${PORTNAME}.1
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/textproc/pdfoutline/distinfo b/textproc/pdfoutline/distinfo
new file mode 100644
index 000000000000..835a9d00ddde
--- /dev/null
+++ b/textproc/pdfoutline/distinfo
@@ -0,0 +1,3 @@
+MD5 (fntsample-2.4.tar.gz) = 013e5f5d6f4035437e67d0ee665de1bd
+SHA256 (fntsample-2.4.tar.gz) = db23d5e5320f7d0447a59370d95aff90bc3c600fa05c111688e0d85642c992a5
+SIZE (fntsample-2.4.tar.gz) = 84348
diff --git a/textproc/pdfoutline/pkg-descr b/textproc/pdfoutline/pkg-descr
new file mode 100644
index 000000000000..e6b2dceec8f9
--- /dev/null
+++ b/textproc/pdfoutline/pkg-descr
@@ -0,0 +1,7 @@
+pdfoutline adds outlines (aka bookmarks) to PDF files. It reads input
+file given as first argument, adds outlines from text file given as
+second argument, and saves result to file with name given as third
+argument.
+
+WWW: http://sourceforge.net/projects/fntsample/
+Author: Eugeniy Meshcheryakov <eugeniy@users.sourceforge.net>