summaryrefslogtreecommitdiff
path: root/textproc/p5-XML-XSLT/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-XSLT/Makefile')
-rw-r--r--textproc/p5-XML-XSLT/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/textproc/p5-XML-XSLT/Makefile b/textproc/p5-XML-XSLT/Makefile
index a31a12a4b788..fbe0c4815aff 100644
--- a/textproc/p5-XML-XSLT/Makefile
+++ b/textproc/p5-XML-XSLT/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
+ ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -23,4 +24,7 @@ MAN1= xslt-parser.1
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= XML::XSLT.3
+test:
+ @cd ${WRKSRC}; ${MAKE} test
+
.include <bsd.port.mk>