summaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Tmpl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Text-Tmpl/Makefile')
-rw-r--r--textproc/p5-Text-Tmpl/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/p5-Text-Tmpl/Makefile b/textproc/p5-Text-Tmpl/Makefile
new file mode 100644
index 000000000000..8fef0c7dbcca
--- /dev/null
+++ b/textproc/p5-Text-Tmpl/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: textproc/p5-Text-Tmpl
+# Date created: 31 December 2000
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Tmpl
+PORTVERSION= 0.23
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= template_syntax.3 Text::Tmpl.3 template_extend.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+ @${PERL} -pi -e '/OPTIMIZE|libtmpl.pod/ and $$_=""' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>