summaryrefslogtreecommitdiff
path: root/textproc/p5-Algorithm-RabinKarp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Algorithm-RabinKarp/Makefile')
-rw-r--r--textproc/p5-Algorithm-RabinKarp/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-Algorithm-RabinKarp/Makefile b/textproc/p5-Algorithm-RabinKarp/Makefile
new file mode 100644
index 000000000000..fab4c8d38ceb
--- /dev/null
+++ b/textproc/p5-Algorithm-RabinKarp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Algorithm-RabinKarp
+# Date created: 24 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-RabinKarp
+PORTVERSION= 0.36
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Rabin-Karp streaming hash
+
+MAN3= Algorithm::RabinKarp.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requres at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>