summaryrefslogtreecommitdiff
path: root/textproc/openvanilla-modules/files
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/openvanilla-modules/files')
-rw-r--r--textproc/openvanilla-modules/files/patch-Modules-Mk-ov.module.mk (renamed from textproc/openvanilla-modules/files/patch-Modules::Mk::ov.module.mk)0
-rw-r--r--textproc/openvanilla-modules/files/patch-Modules-OVIMBoshiamy-Makefile11
-rw-r--r--textproc/openvanilla-modules/files/patch-Modules-OVIMSpaceChewing-Makefile13
-rw-r--r--textproc/openvanilla-modules/files/patch-Modules-OVIMSpaceChewing0.3-Makefile11
-rw-r--r--textproc/openvanilla-modules/files/patch-Modules-SharedHeaders-OVFileHandler.h13
-rw-r--r--textproc/openvanilla-modules/files/patch-Modules::SharedHeaders::OVFileHandler.h13
6 files changed, 48 insertions, 13 deletions
diff --git a/textproc/openvanilla-modules/files/patch-Modules::Mk::ov.module.mk b/textproc/openvanilla-modules/files/patch-Modules-Mk-ov.module.mk
index aa430813df8c..aa430813df8c 100644
--- a/textproc/openvanilla-modules/files/patch-Modules::Mk::ov.module.mk
+++ b/textproc/openvanilla-modules/files/patch-Modules-Mk-ov.module.mk
diff --git a/textproc/openvanilla-modules/files/patch-Modules-OVIMBoshiamy-Makefile b/textproc/openvanilla-modules/files/patch-Modules-OVIMBoshiamy-Makefile
new file mode 100644
index 000000000000..41eff6367753
--- /dev/null
+++ b/textproc/openvanilla-modules/files/patch-Modules-OVIMBoshiamy-Makefile
@@ -0,0 +1,11 @@
+--- Modules/OVIMBoshiamy/Makefile.orig Mon May 14 14:23:33 2007
++++ Modules/OVIMBoshiamy/Makefile Tue May 15 22:09:09 2007
+@@ -4,7 +4,7 @@
+ SOURCES=OVIMBoshiamy
+ DATA=imtables.db
+ CINS=liu5.cin
+-LDFLAGS+=-lsqlite3
++LDFLAGS+=-lsqlite3 -L${LOCALBASE}/lib
+ EXTRA_GOALS=imtables.db
+
+ include ../Mk/ov.module.mk
diff --git a/textproc/openvanilla-modules/files/patch-Modules-OVIMSpaceChewing-Makefile b/textproc/openvanilla-modules/files/patch-Modules-OVIMSpaceChewing-Makefile
new file mode 100644
index 000000000000..a79f69ad84ab
--- /dev/null
+++ b/textproc/openvanilla-modules/files/patch-Modules-OVIMSpaceChewing-Makefile
@@ -0,0 +1,13 @@
+--- Modules/OVIMSpaceChewing/Makefile.orig Mon May 14 14:23:34 2007
++++ Modules/OVIMSpaceChewing/Makefile Tue May 15 22:20:23 2007
+@@ -31,8 +31,8 @@
+ MODULEID=OVIMSpaceChewing
+ SOURCES=OVIMSpaceChewing
+
+-LIBCHEWING_PREFIX?=/usr/local
+-LIBCHEWING_VERSION?=$(shell perl -n -e 'print "$$1\n" if /Version: (.+)/' < $(LIBCHEWING_PREFIX)/lib/pkgconfig/chewing.pc)
++LIBCHEWING_PREFIX?=${LOCALBASE}
++LIBCHEWING_VERSION?=$(shell perl -n -e 'print "$$1\n" if /Version: (.+)/' < $(LIBCHEWING_PREFIX)/libdata/pkgconfig/chewing.pc)
+
+ DATA=$(LIBCHEWING_PREFIX)/share/chewing/ch_index.dat \
+ $(LIBCHEWING_PREFIX)/share/chewing/dict.dat \
diff --git a/textproc/openvanilla-modules/files/patch-Modules-OVIMSpaceChewing0.3-Makefile b/textproc/openvanilla-modules/files/patch-Modules-OVIMSpaceChewing0.3-Makefile
new file mode 100644
index 000000000000..007cdeff917b
--- /dev/null
+++ b/textproc/openvanilla-modules/files/patch-Modules-OVIMSpaceChewing0.3-Makefile
@@ -0,0 +1,11 @@
+--- Modules/OVIMSpaceChewing0.3/Makefile.orig Tue May 15 22:36:11 2007
++++ Modules/OVIMSpaceChewing0.3/Makefile Tue May 15 22:36:11 2007
+@@ -17,7 +17,7 @@
+
+ data:
+ cd libchewing/tool/; make;
+- svn cat http://svn.openfoundry.org/libchewingdata/utf-8/tsi.src > chewingdata/tsi.src
++ #svn cat http://svn.openfoundry.org/libchewingdata/utf-8/tsi.src > chewingdata/tsi.src
+ cd chewingdata/; ../libchewing/tool/sort_word;
+ cd chewingdata/; ../libchewing/tool/sort_dic tsi.src;
+ cd chewingdata/; ../libchewing/tool/maketree;
diff --git a/textproc/openvanilla-modules/files/patch-Modules-SharedHeaders-OVFileHandler.h b/textproc/openvanilla-modules/files/patch-Modules-SharedHeaders-OVFileHandler.h
new file mode 100644
index 000000000000..178ac1900dbb
--- /dev/null
+++ b/textproc/openvanilla-modules/files/patch-Modules-SharedHeaders-OVFileHandler.h
@@ -0,0 +1,13 @@
+--- Modules/SharedHeaders/OVFileHandler.h.orig Mon May 14 14:23:35 2007
++++ Modules/SharedHeaders/OVFileHandler.h Tue May 15 21:07:16 2007
+@@ -43,9 +43,9 @@
+ HANDLE hMap;
+ } MmapHandles;
+ #else
++ #include <sys/types.h>
+ #include <sys/mman.h>
+ #include <sys/stat.h>
+- #include <sys/types.h>
+ #include <stdio.h>
+ #include <fcntl.h>
+ #include <unistd.h>
diff --git a/textproc/openvanilla-modules/files/patch-Modules::SharedHeaders::OVFileHandler.h b/textproc/openvanilla-modules/files/patch-Modules::SharedHeaders::OVFileHandler.h
deleted file mode 100644
index 0c05b9e380f5..000000000000
--- a/textproc/openvanilla-modules/files/patch-Modules::SharedHeaders::OVFileHandler.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- Modules/SharedHeaders/OVFileHandler.h.orig Tue Feb 14 00:18:36 2006
-+++ Modules/SharedHeaders/OVFileHandler.h Mon Mar 20 16:19:33 2006
-@@ -36,9 +36,9 @@
- #include <fstream>
-
- #ifndef WIN32
-+ #include <sys/types.h>
- #include <sys/mman.h>
- #include <sys/stat.h>
-- #include <sys/types.h>
- #include <stdio.h>
- #include <fcntl.h>
- #include <unistd.h>