summaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/libchk/Makefile9
-rw-r--r--sysutils/portupgrade-devel/Makefile5
-rw-r--r--sysutils/portupgrade/Makefile5
3 files changed, 4 insertions, 15 deletions
diff --git a/sysutils/libchk/Makefile b/sysutils/libchk/Makefile
index 7aa2bbea6d5f..6f5351824e3e 100644
--- a/sysutils/libchk/Makefile
+++ b/sysutils/libchk/Makefile
@@ -16,16 +16,11 @@ MAINTAINER= knu@FreeBSD.org
USE_BZIP2= yes
USE_RUBY= yes
+USE_RUBY_FEATURES= optparse
MAKE_ARGS= PREFIX="${PREFIX}"
MAN1= libchk.1
MANCOMPRESSED= maybe
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/portupgrade-devel/Makefile b/sysutils/portupgrade-devel/Makefile
index 16aed7712e66..897ced101ff4 100644
--- a/sysutils/portupgrade-devel/Makefile
+++ b/sysutils/portupgrade-devel/Makefile
@@ -30,6 +30,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/bdb1.so:${PORTSDIR}/databases/ruby-bdb1
USE_BZIP2= yes
USE_RUBY= yes
+USE_RUBY_FEATURES= optparse ruby18
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -63,10 +64,6 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
IGNORE= pkg_create does not support -b. Please update pkg_* tools or stick with portupgrade-20020920 + pkg_tarup-1.2_3, which work just fine
.endif
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file_ruby18.so:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index 16aed7712e66..897ced101ff4 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -30,6 +30,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/bdb1.so:${PORTSDIR}/databases/ruby-bdb1
USE_BZIP2= yes
USE_RUBY= yes
+USE_RUBY_FEATURES= optparse ruby18
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -63,10 +64,6 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
IGNORE= pkg_create does not support -b. Please update pkg_* tools or stick with portupgrade-20020920 + pkg_tarup-1.2_3, which work just fine
.endif
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file_ruby18.so:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \