summaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/f3/Makefile32
-rw-r--r--sysutils/f3/distinfo2
-rw-r--r--sysutils/f3/pkg-descr8
4 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c6c6eb4c783d..faf98d32f31d 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -217,6 +217,7 @@
SUBDIR += exfat-utils
SUBDIR += extipl
SUBDIR += ezjail
+ SUBDIR += f3
SUBDIR += fanout
SUBDIR += farbot
SUBDIR += fastest_cvsup
diff --git a/sysutils/f3/Makefile b/sysutils/f3/Makefile
new file mode 100644
index 000000000000..d4ee264b175a
--- /dev/null
+++ b/sysutils/f3/Makefile
@@ -0,0 +1,32 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= f3
+PORTVERSION= 4.0
+CATEGORIES= sysutils
+
+MAINTAINER= uffe@uffe.org
+COMMENT= Fight Flash Fraud or Fight Fake Flash test tool
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= AltraMayor
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 55d2017
+
+USES= gmake pathfix shebangfix
+
+SHEBANG_FILES= f3write.h2w log-f3wr
+
+PLIST_FILES= bin/f3read bin/f3write bin/f3write.h2w \
+ bin/log-f3wr man/man1/f3read.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/f3read ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/f3write ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/f3write.h2w ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/log-f3wr ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/f3read.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/f3/distinfo b/sysutils/f3/distinfo
new file mode 100644
index 000000000000..9680704e46b9
--- /dev/null
+++ b/sysutils/f3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (f3-4.0.tar.gz) = 735e79d58c8be457f69d724989ee0ef81bc4a06248ed8d8b94b6615aa59018c5
+SIZE (f3-4.0.tar.gz) = 21984
diff --git a/sysutils/f3/pkg-descr b/sysutils/f3/pkg-descr
new file mode 100644
index 000000000000..9f53d27266b6
--- /dev/null
+++ b/sysutils/f3/pkg-descr
@@ -0,0 +1,8 @@
+F3 (Fight Flash Fraud or Fight Fake Flash) tests the full capacity
+of a flash card (flash drive, flash disk, pendrive). It writes to
+the card and then checks if it can read it. It will assure that
+you haven't been sold a card with a smaller capacity than stated.
+
+WARNING: All data on the tested disk might be lost!
+
+WWW: http://oss.digirati.com.br/f3