summaryrefslogtreecommitdiff
path: root/sysutils/rsnapshot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/rsnapshot/Makefile')
-rw-r--r--sysutils/rsnapshot/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/rsnapshot/Makefile b/sysutils/rsnapshot/Makefile
new file mode 100644
index 000000000000..d7ee5543f473
--- /dev/null
+++ b/sysutils/rsnapshot/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: rsnapshot
+# Date created: 2004-01-03
+# Whom: Ralf van Dooren <r.vdooren@snow.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rsnapshot
+PORTVERSION= 1.0.9
+CATEGORIES= sysutils
+MASTER_SITES= http://www.rsnapshot.org/downloads/
+
+MAINTAINER= r.vdooren@snow.nl
+COMMENT= Filesystem snapshot utility based on rsync(1)
+
+RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
+
+USE_PERL5= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= rsnapshot.1
+DOCS= AUTHORS ChangeLog README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>