summaryrefslogtreecommitdiff
path: root/sysutils/pear-File_Fstab/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/pear-File_Fstab/Makefile')
-rw-r--r--sysutils/pear-File_Fstab/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/pear-File_Fstab/Makefile b/sysutils/pear-File_Fstab/Makefile
new file mode 100644
index 000000000000..6fda8f3a9a95
--- /dev/null
+++ b/sysutils/pear-File_Fstab/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: pear-File_Fstab
+# Date created: 09 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= File_Fstab
+PORTVERSION= 2.0.1
+CATEGORIES= sysutils devel pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class to read and write fstab files
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= File
+FILES= Fstab.php Fstab/Entry.php
+EXAMPLES= example.php
+_EXAMPLESDIR= .
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/Fstab
+ @${MV} ${WRKSRC}/Entry.php ${WRKSRC}/Fstab
+.for file in ${FILES}
+ @${REINPLACE_CMD} -e "s|@package@|${PORTNAME}|" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e "s|@version@|${PORTVERSION}|" ${WRKSRC}/${file}
+.endfor
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>