summaryrefslogtreecommitdiff
path: root/sysutils/lineakd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/lineakd/Makefile')
-rw-r--r--sysutils/lineakd/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/sysutils/lineakd/Makefile b/sysutils/lineakd/Makefile
index 8621d9184519..f1cfd8435f2a 100644
--- a/sysutils/lineakd/Makefile
+++ b/sysutils/lineakd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lineakd
PORTVERSION= 0.8.3
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=lineak
@@ -17,6 +18,7 @@ COMMENT= Lineakd is a daemon which enables special keys on internet keyboards
USE_GMAKE= yes
USE_XLIB= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${X11BASE}/lib ${PTHREAD_LIBS}"
USE_REINPLACE= yes
@@ -34,10 +36,6 @@ MANCOMPRESSED= yes
.if ${OSVERSION} < 500000
# ANSI C++ forbids data member `macro_info' with same name as enclosing class
USE_GCC= 3.4
-GNU_CONFIGURE= yes
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-ltmain.sh
-.else
-USE_AUTOTOOLS= libtool:15
.endif
post-patch: