summaryrefslogtreecommitdiff
path: root/sysutils/lineak-xosdplugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/lineak-xosdplugin/Makefile')
-rw-r--r--sysutils/lineak-xosdplugin/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/sysutils/lineak-xosdplugin/Makefile b/sysutils/lineak-xosdplugin/Makefile
index f2066ab7f7fc..acd5ca6517ee 100644
--- a/sysutils/lineak-xosdplugin/Makefile
+++ b/sysutils/lineak-xosdplugin/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --program-prefix=''
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= lineak_xosdplugin.1
MAN_COMPRESSED= yes
@@ -41,5 +41,6 @@ BROKEN= Configure fails to find lineakd
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
.include <bsd.port.post.mk>