summaryrefslogtreecommitdiff
path: root/sysutils/dd_rescue/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/dd_rescue/Makefile')
-rw-r--r--sysutils/dd_rescue/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/sysutils/dd_rescue/Makefile b/sysutils/dd_rescue/Makefile
index fcbc48e2adef..3ec89f7eaa69 100644
--- a/sysutils/dd_rescue/Makefile
+++ b/sysutils/dd_rescue/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dd_rescue
-PORTVERSION= 1.40
+PORTVERSION= 1.45
CATEGORIES= sysutils
MASTER_SITES= http://www.garloff.de/kurt/linux/ddrescue/ \
http://fossies.org/unix/privat/
@@ -22,9 +22,17 @@ ALL_TARGET= default
OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dd_rescue ${STAGEDIR}${PREFIX}/bin
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/libddr_hash.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/libddr_null.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_MAN} ${WRKSRC}/dd_rescue.1 ${STAGEDIR}${PREFIX}/man/man1
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.dd_rescue ${STAGEDIR}${DOCSDIR}
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>