summaryrefslogtreecommitdiff
path: root/sysutils/acidlaunch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/acidlaunch/Makefile')
-rw-r--r--sysutils/acidlaunch/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/acidlaunch/Makefile b/sysutils/acidlaunch/Makefile
new file mode 100644
index 000000000000..74f6fb2c3eb1
--- /dev/null
+++ b/sysutils/acidlaunch/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: acidlaunch
+# Date created: 11 Apr 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= acidlaunch
+PORTVERSION= 0.5
+CATEGORIES= sysutils windowmaker
+MASTER_SITES= http://linuxgamers.net/download/
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= An application launcher with simple XML-based configuration syntax
+
+HAS_CONFIGURE= yes
+USE_GNOME= gtk12 gdkpixbuf libxml2
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+MAN1= ${PORTNAME}.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/${PORTNAME}
+.for file in config.xml default.png
+ ${INSTALL_DATA} ${WRKSRC}/prefs/${file} ${PREFIX}/share/${PORTNAME}
+.endfor
+ @${INSTALL_MAN} ${WRKSRC}/docs/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>