summaryrefslogtreecommitdiff
path: root/security/snort
diff options
context:
space:
mode:
Diffstat (limited to 'security/snort')
-rw-r--r--security/snort/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 64d137170a45..9b89b934bd80 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -60,6 +60,13 @@ MAN8= snort.8
DOCS= ChangeLog doc/AUTHORS doc/BUGS doc/CREDITS doc/FAQ doc/NEWS \
doc/README* doc/TODO doc/USAGE doc/snort_manual.pdf
+OPTIONS= FLEXRESP "Flexible response to events" off \
+ MYSQL "Mysql logging" off \
+ ODBC "ODBC logging" off \
+ POSTGRES "Postgresql logging" off
+
+.include <bsd.port.pre.mk>
+
post-patch:
${REINPLACE_CMD} "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/src/snort.c
@@ -92,4 +99,4 @@ post-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>