summaryrefslogtreecommitdiff
path: root/security/libgnome-keyring
diff options
context:
space:
mode:
Diffstat (limited to 'security/libgnome-keyring')
-rw-r--r--security/libgnome-keyring/Makefile28
-rw-r--r--security/libgnome-keyring/distinfo3
-rw-r--r--security/libgnome-keyring/pkg-descr3
-rw-r--r--security/libgnome-keyring/pkg-plist88
4 files changed, 122 insertions, 0 deletions
diff --git a/security/libgnome-keyring/Makefile b/security/libgnome-keyring/Makefile
new file mode 100644
index 000000000000..83f2831f3fc4
--- /dev/null
+++ b/security/libgnome-keyring/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libgnome-keyring
+# Date created: 2009-12-21
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/security/libgnome-keyring/Makefile,v 1.3 2010/04/27 16:37:52 kwm Exp $
+
+PORTNAME= libgnome-keyring
+PORTVERSION= 2.30.1
+CATEGORIES= security gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A program that keeps passwords and other secrets
+
+LIB_DEPENDS= tasn1.4:${PORTSDIR}/security/libtasn1 \
+ gcrypt.16:${PORTSDIR}/security/libgcrypt
+
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnomeprefix ltverhack intlhack gconf2
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_AUTOTOOLS= libtool:22
+USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/security/libgnome-keyring/distinfo b/security/libgnome-keyring/distinfo
new file mode 100644
index 000000000000..b0afae706eca
--- /dev/null
+++ b/security/libgnome-keyring/distinfo
@@ -0,0 +1,3 @@
+MD5 (libgnome-keyring-2.30.1.tar.bz2) = 11ce9e5ca66cf934e243ddd68f52adc9
+SHA256 (libgnome-keyring-2.30.1.tar.bz2) = a9227da7d3eee930b75ad7858875344b713d1bf73e6af54870a2691643d5dae4
+SIZE (libgnome-keyring-2.30.1.tar.bz2) = 812131
diff --git a/security/libgnome-keyring/pkg-descr b/security/libgnome-keyring/pkg-descr
new file mode 100644
index 000000000000..90cedeaf7541
--- /dev/null
+++ b/security/libgnome-keyring/pkg-descr
@@ -0,0 +1,3 @@
+Gnome-keyring is a program that keep password and other secrets for
+users. The library libgnome-keyring is used by applications to integrate
+with the gnome keyring system.
diff --git a/security/libgnome-keyring/pkg-plist b/security/libgnome-keyring/pkg-plist
new file mode 100644
index 000000000000..7a0f7b41f1db
--- /dev/null
+++ b/security/libgnome-keyring/pkg-plist
@@ -0,0 +1,88 @@
+include/gnome-keyring-1/gnome-keyring-memory.h
+include/gnome-keyring-1/gnome-keyring-result.h
+include/gnome-keyring-1/gnome-keyring.h
+lib/libgnome-keyring.a
+lib/libgnome-keyring.la
+lib/libgnome-keyring.so
+lib/libgnome-keyring.so.0
+libdata/pkgconfig/gnome-keyring-1.pc
+share/doc/gnome-keyring/ch01.html
+share/doc/gnome-keyring/gnome-keyring-Callbacks.html
+share/doc/gnome-keyring/gnome-keyring-Item-ACLs.html
+share/doc/gnome-keyring/gnome-keyring-Item-Attributes.html
+share/doc/gnome-keyring/gnome-keyring-Item-Information.html
+share/doc/gnome-keyring/gnome-keyring-Keyring-Info.html
+share/doc/gnome-keyring/gnome-keyring-Keyring-Items.html
+share/doc/gnome-keyring/gnome-keyring-Keyrings.html
+share/doc/gnome-keyring/gnome-keyring-Network-Passwords.html
+share/doc/gnome-keyring/gnome-keyring-Non-pageable-Memory.html
+share/doc/gnome-keyring/gnome-keyring-Result-Codes.html
+share/doc/gnome-keyring/gnome-keyring-Search-Functionality.html
+share/doc/gnome-keyring/gnome-keyring.devhelp
+share/doc/gnome-keyring/gnome-keyring.devhelp2
+share/doc/gnome-keyring/home.png
+share/doc/gnome-keyring/index.html
+share/doc/gnome-keyring/index.sgml
+share/doc/gnome-keyring/left.png
+share/doc/gnome-keyring/right.png
+share/doc/gnome-keyring/style.css
+share/doc/gnome-keyring/up.png
+share/locale/ar/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ast/LC_MESSAGES/libgnome-keyring.mo
+share/locale/bg/LC_MESSAGES/libgnome-keyring.mo
+share/locale/bn/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ca/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ca@valencia/LC_MESSAGES/libgnome-keyring.mo
+share/locale/cs/LC_MESSAGES/libgnome-keyring.mo
+share/locale/da/LC_MESSAGES/libgnome-keyring.mo
+share/locale/de/LC_MESSAGES/libgnome-keyring.mo
+share/locale/el/LC_MESSAGES/libgnome-keyring.mo
+share/locale/en_GB/LC_MESSAGES/libgnome-keyring.mo
+share/locale/es/LC_MESSAGES/libgnome-keyring.mo
+share/locale/et/LC_MESSAGES/libgnome-keyring.mo
+share/locale/eu/LC_MESSAGES/libgnome-keyring.mo
+share/locale/fi/LC_MESSAGES/libgnome-keyring.mo
+share/locale/fr/LC_MESSAGES/libgnome-keyring.mo
+share/locale/gl/LC_MESSAGES/libgnome-keyring.mo
+share/locale/hu/LC_MESSAGES/libgnome-keyring.mo
+share/locale/id/LC_MESSAGES/libgnome-keyring.mo
+share/locale/it/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ja/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ko/LC_MESSAGES/libgnome-keyring.mo
+share/locale/lt/LC_MESSAGES/libgnome-keyring.mo
+share/locale/lv/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ml/LC_MESSAGES/libgnome-keyring.mo
+share/locale/mn/LC_MESSAGES/libgnome-keyring.mo
+share/locale/nb/LC_MESSAGES/libgnome-keyring.mo
+share/locale/nds/LC_MESSAGES/libgnome-keyring.mo
+share/locale/nl/LC_MESSAGES/libgnome-keyring.mo
+share/locale/nn/LC_MESSAGES/libgnome-keyring.mo
+share/locale/pa/LC_MESSAGES/libgnome-keyring.mo
+share/locale/pl/LC_MESSAGES/libgnome-keyring.mo
+share/locale/pt/LC_MESSAGES/libgnome-keyring.mo
+share/locale/pt_BR/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ro/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ru/LC_MESSAGES/libgnome-keyring.mo
+share/locale/sk/LC_MESSAGES/libgnome-keyring.mo
+share/locale/sl/LC_MESSAGES/libgnome-keyring.mo
+share/locale/sr/LC_MESSAGES/libgnome-keyring.mo
+share/locale/sr@latin/LC_MESSAGES/libgnome-keyring.mo
+share/locale/sv/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ta/LC_MESSAGES/libgnome-keyring.mo
+share/locale/th/LC_MESSAGES/libgnome-keyring.mo
+share/locale/uk/LC_MESSAGES/libgnome-keyring.mo
+share/locale/zh_CN/LC_MESSAGES/libgnome-keyring.mo
+share/locale/zh_HK/LC_MESSAGES/libgnome-keyring.mo
+share/locale/zh_TW/LC_MESSAGES/libgnome-keyring.mo
+@dirrmtry share/local/zh_HK/LC_MESSAGES
+@dirrmtry share/local/zh_HK
+@dirrmtry share/local/sr@latin/LC_MESSAGES
+@dirrmtry share/local/sr@latin
+@dirrmtry share/local/nds/LC_MESSAGES
+@dirrmtry share/local/nds
+@dirrmtry share/local/ca@valencia/LC_MESSAGES
+@dirrmtry share/local/ca@valencia
+@dirrmtry share/local/ast/LC_MESSAGES
+@dirrmtry share/local/ast
+@dirrm share/doc/gnome-keyring
+@dirrm include/gnome-keyring-1