summaryrefslogtreecommitdiff
path: root/security/hs-RSA/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hs-RSA/Makefile')
-rw-r--r--security/hs-RSA/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/security/hs-RSA/Makefile b/security/hs-RSA/Makefile
index 30aef7812354..11a45a1d0854 100644
--- a/security/hs-RSA/Makefile
+++ b/security/hs-RSA/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: hs-RSA
-# Date created: December 26, 2011
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= RSA
-PORTVERSION= 1.2.1.0
-PORTREVISION= 1
+PORTVERSION= 1.2.2.0
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -16,7 +10,7 @@ COMMENT= Implementation of RSA, using the padding schemes of PKCS#1 v2.1
LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= crypto-api>=0.10 crypto-pubkey-types monadcryptorandom SHA
+USE_CABAL= crypto-api>=0.10 crypto-pubkey-types>=0.2 monadcryptorandom SHA
OPTIONS_DEFINE= MD5 BINARY
OPTIONS_DEFAULT= MD5 BINARY
@@ -24,7 +18,7 @@ OPTIONS_DEFAULT= MD5 BINARY
MD5_DESC= Include support for using MD5
BINARY_DESC= Use the binary package for serialization
-.include <bsd.port.options.mk>
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.if ${PORT_OPTIONS:MMD5}
CONFIGURE_ARGS+= --flags="IncludeMD5"