summaryrefslogtreecommitdiff
path: root/security/gnome-keyring/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/gnome-keyring/Makefile')
-rw-r--r--security/gnome-keyring/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/security/gnome-keyring/Makefile b/security/gnome-keyring/Makefile
index f4e78d323888..7c55f7c7fcbc 100644
--- a/security/gnome-keyring/Makefile
+++ b/security/gnome-keyring/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/security/gnome-keyring/Makefile,v 1.6 2010/06/23 12:38:25 kwm Exp $
+# $MCom: ports/security/gnome-keyring/Makefile,v 1.98 2010/10/26 08:18:44 kwm Exp $
#
PORTNAME= gnome-keyring
-PORTVERSION= 2.30.3
-PORTREVISION= 1
+PORTVERSION= 2.32.1
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,16 +16,19 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A program that keeps passwords and other secrets
LIB_DEPENDS= gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
USE_BZIP2= yes
-USE_GNOME= gnomehack gnomeprefix gtk20 ltverhack intlhack gconf2
+USE_GNOME= gnomehack gnomeprefix gtk20 ltverhack intlhack
USE_GMAKE= yes
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-pam-dir="${PREFIX}/lib"
+CONFIGURE_ARGS= --with-pam-dir="${PREFIX}/lib" \
+ --with-root-certs="${LOCALBASE}/share/certs/ca-root-nss.crt"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-GCONF_SCHEMAS= gnome-keyring.schemas
+GLIB_SCHEMAS= org.gnome.crypto.cache.gschema.xml \
+ org.gnome.crypto.pgp.gschema.xml
.include <bsd.port.mk>