summaryrefslogtreecommitdiff
path: root/security/dsniff/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/dsniff/Makefile')
-rw-r--r--security/dsniff/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index c24d669ee78f..a26f162eafba 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -16,10 +16,18 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet \
${LOCALBASE}/lib/libnids.a:${PORTSDIR}/net/libnids
GNU_CONFIGURE= yes
-USE_XLIB= yes
MAN8= arpspoof.8 dsniff.8 macof.8 mailsnarf.8 tcpkill.8 \
- tcpnice.8 urlsnarf.8 webspy.8 filesnarf.8 dnsspoof.8 msgsnarf.8 \
+ tcpnice.8 urlsnarf.8 filesnarf.8 dnsspoof.8 msgsnarf.8 \
sshmitm.8 webmitm.8
+.if !defined(WITHOUT_X11)
+USE_XLIB= yes
+PLIST_SUB+= X11=''
+.else
+CONFIGURE_ARGS+= --without-x
+PLIST_SUB+= X11='@comment '
+MAN8+= webspy.8
+.endif
+
.include <bsd.port.mk>