summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/2dhf/Makefile8
-rw-r--r--science/mpqc/Makefile8
2 files changed, 10 insertions, 6 deletions
diff --git a/science/2dhf/Makefile b/science/2dhf/Makefile
index f947418275b0..f193487b2de5 100644
--- a/science/2dhf/Makefile
+++ b/science/2dhf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= 2dhf
PORTVERSION= 2005.05
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= http://www.fizyka.umk.pl/~jkob/2dhf/
DISTNAME= ${PORTNAME}-05.05
@@ -34,8 +34,10 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
.endif
-WANT_FORTRAN=yes
-USE_GCC=4.2+
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
.if defined(WITH_OPTIMIZED_FLAGS)
FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index bfe823a97b7f..7db707c564be 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpqc
PORTVERSION= 2.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science parallel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mpqc
@@ -50,8 +50,10 @@ BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:259
-WANT_FORTRAN=yes
-USE_GCC=4.2+
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
.if defined(WITH_ICC)
CC= ${LOCALBASE}/intel_cc_80/bin/icc