summaryrefslogtreecommitdiff
path: root/science/ecs
diff options
context:
space:
mode:
Diffstat (limited to 'science/ecs')
-rw-r--r--science/ecs/Makefile27
-rw-r--r--science/ecs/distinfo6
2 files changed, 22 insertions, 11 deletions
diff --git a/science/ecs/Makefile b/science/ecs/Makefile
index ad198df02e3c..a67abb1b53ac 100644
--- a/science/ecs/Makefile
+++ b/science/ecs/Makefile
@@ -6,9 +6,11 @@
#
PORTNAME= ecs
-PORTVERSION= 1.3.1
+PORTVERSION= 1.3.2
CATEGORIES= science
-MASTER_SITES= http://www.edf.fr/html/RetD/livraison_saturne_${REL_DATE}/
+MASTER_SITES= http://rd.edf.com/fichiers/fckeditor/File/EDF%20RD/Code_Saturne/Fichiers/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .tgz
MAINTAINER= thierry@FreeBSD.org
COMMENT= Code_Saturne Preprocessor
@@ -18,15 +20,15 @@ LIB_DEPENDS= med.2:${PORTSDIR}/french/med \
hdf5.0:${PORTSDIR}/science/hdf5 \
cgns.0:${PORTSDIR}/science/cgnslib
-REL_DATE= 20071218
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-bft-prefix=${LOCALBASE} \
- --with-hdf5-prefix=${LOCALBASE} \
- --with-cgns-prefix=${LOCALBASE} \
- --with-med-prefix=${LOCALBASE} \
- --with-metis-prefix=${LOCALBASE}
+CONFIGURE_ARGS= --with-bft=${LOCALBASE} \
+ --with-hdf5=${LOCALBASE} \
+ --with-cgns=${LOCALBASE} \
+ --with-med=${LOCALBASE} \
+ --with-metis=${LOCALBASE}
CONFIGURE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
.if defined(WITHOUT_NLS)
@@ -42,7 +44,11 @@ PLIST_SUB+= NLS=""
CONFIGURE_ARGS+= --enable-debug
.endif
+NOPORTDOCS= yes # PDF not produced ATM
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= pdflatex:${PORTSDIR}/print/teTeX-base
PORTDOCS= mi_ecs.pdf mu_ecs.pdf
+.endif
.include <bsd.port.pre.mk>
@@ -54,6 +60,11 @@ LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis-edf
.endif
+pre-configure:
+.if !defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e '/^SUBDIRS/s| po| po doc|' ${WRKSRC}/Makefile.in
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/science/ecs/distinfo b/science/ecs/distinfo
index 10a02596c228..ebbff856d3e7 100644
--- a/science/ecs/distinfo
+++ b/science/ecs/distinfo
@@ -1,3 +1,3 @@
-MD5 (ecs-1.3.1.tar.gz) = 27a595d350952dea2221633ccf311934
-SHA256 (ecs-1.3.1.tar.gz) = bdd5c9c85e40567e95a6b93f5b836344410ba167984aa88bd764dfda0fea7926
-SIZE (ecs-1.3.1.tar.gz) = 2085349
+MD5 (ecs-132.tgz) = 45c2b164ab1b82aa9f7e776f8566594d
+SHA256 (ecs-132.tgz) = 85122081b2f670a990df14a3b40190e9a615add8c82110006ae3250476149867
+SIZE (ecs-132.tgz) = 1225995