summaryrefslogtreecommitdiff
path: root/print/guitartex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--print/guitartex/Makefile29
1 files changed, 24 insertions, 5 deletions
diff --git a/print/guitartex/Makefile b/print/guitartex/Makefile
index fe889969d2f4..1fc713ed6ad6 100644
--- a/print/guitartex/Makefile
+++ b/print/guitartex/Makefile
@@ -7,10 +7,13 @@
#
PORTNAME= guitartex
-PORTVERSION= 2.4.1
+PORTVERSION= 2.8.2
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+## Hack just for this "fix version"
+DISTNAME= ${PORTNAME}-${PORTVERSION}-fix1
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GuitarTeX converts the Chord format into "normal" LaTeX format
@@ -22,12 +25,28 @@ USE_REINPLACE= yes
USE_PERL5= yes
NO_BUILD= yes
-post-patch:
- @${REINPLACE_CMD} -e "s,\"\(.*\.gif\)\",\"${DATADIR}/\1\",g" ${WRKSRC}/guitartex
+do-configure:
+ @${REINPLACE_CMD} -e 's!/usr/local/lib/guitartex!${DATADIR}!g' ${WRKSRC}/gtx2tex.pl
+ @${REINPLACE_CMD} -e 's!/usr/local/lib/guitartex!${DATADIR}!g' ${WRKSRC}/guitartex.pl
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/guitartex ${PREFIX}/bin
+ ${INSTALL} ${WRKSRC}/gtx2tex.pl ${PREFIX}/bin
+ ${INSTALL} ${WRKSRC}/guitartex.pl ${PREFIX}/bin
@${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/*.gif ${WRKSRC}/*.ps ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/guitartex.conf ${DATADIR}
+ @${MKDIR} ${DATADIR}/images
+ ${INSTALL_DATA} ${WRKSRC}/images/* ${DATADIR}/images
+ @${MKDIR} ${DATADIR}/language
+ ${INSTALL_DATA} ${WRKSRC}/language/* ${DATADIR}/language/
+ @${MKDIR} ${DATADIR}/templates
+ ${INSTALL_DATA} ${WRKSRC}/templates/* ${DATADIR}/templates
+
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -Rp ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>