summaryrefslogtreecommitdiff
path: root/ports-mgmt/portupgrade-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/portupgrade-devel/Makefile')
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 5f3e0bc48089..252842ea2a77 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -6,25 +6,32 @@
#
PORTNAME= portupgrade
-PORTVERSION= 20020204
+PORTVERSION= 20020213
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.iDaemons.org/distfiles/
MASTER_SITE_SUBDIR= knu
-DISTNAME= pkgtools-${PORTVERSION}
+DISTNAME= pkgtools-${PREV_PORTVERSION}
-#PATCH_SITES= ${MASTER_SITES}
-#PATCHFILES= pkgtools-${PORTVERSION}.patch.gz
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= pkgtools-${PREV_PORTVERSION}-${PORTVERSION}.diff.bz2
+PATCH_DIST_STRIP= -p1
MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse \
${RUBY_SITEARCHLIBDIR}/fnmatch.so:${PORTSDIR}/devel/ruby-fnmatch \
${LOCALBASE}/sbin/pkg_tarup:${PORTSDIR}/sysutils/pkg_tarup
+# For PKG_DBDRIVER={bdb1_btree,btree,bdb1_hash,hash,bdb1}
+# ${RUBY_SITEARCHLIBDIR}/bdb1.so:${PORTSDIR}/databases/ruby-bdb1
+# For PKG_DBDRIVER={bdb_btree,bdb_hash,bdb}
+# ${RUBY_SITEARCHLIBDIR}/bdb.so:${PORTSDIR}/databases/ruby-bdb
USE_BZIP2= yes
USE_RUBY= yes
+PREV_PORTVERSION= 20020204
+
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
MAN1= pkg_deinstall.1 \