summaryrefslogtreecommitdiff
path: root/news/nntpcache/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/nntpcache/Makefile')
-rw-r--r--news/nntpcache/Makefile62
1 files changed, 32 insertions, 30 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 7c265d9006b9..642d058671df 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -6,46 +6,48 @@
#
PORTNAME= nntpcache
-PORTVERSION= 2.4.0b2
+PORTVERSION= 2.4.0b5
CATEGORIES= news
MASTER_SITES= ftp://nntpcache.org/pub/nntpcache/ \
- ftp://ftp.ntnu.no/pub/unix/news/nntpcache/ \
- ftp://ftp.nethelp.no/pub/unix/news/ \
- ftp://suburbia.net/pub/nntpcache/
+ ftp://ftp.nethelp.no/pub/news/ \
+ ftp://ftp.netsw.org/net/news/proxy/nntpcache/
-MAINTAINER= nntpcache@nntpcache.org
+MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= pgp:${PORTSDIR}/security/pgp
+#BUILD_DEPENDS= pgp:${PORTSDIR}/security/pgp
-GNU_CONFIGURE= TRUE
-CONFIGURE_ARGS= --localstatedir=/var/spool
+# This may be set interactively at install-time. NNTPCache will
+# cache news articles and related data in ${SPOOLDIR}/nntpcache.
+SPOOLDIR?= /var/spool
+
+NO_CDROM= Free for individuals and non-military, non-profit organisations only
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${SPOOLDIR}
+NNTPSPOOLDIR?= ${SPOOLDIR}/${PORTNAME}
+PLIST_SUB+= SPOOLDIR=${NNTPSPOOLDIR}
+CPIO= cpio --quiet -pdum -R
MAN8= nntpcached.8 newshound.8
-DOCS= AUTHORS ChangeLog FAQ FAQ.html HACKING \
+DOCS= AUTHORS ChangeLog FAQ FAQ.html HACKING HTML \
INSTALL LICENSING NEWS README README.INN VERSION
-USE_GMAKE= TRUE
-
-post-configure:
- @${SED} -e "s:%%PREFIX%%:${PREFIX}:g" \
- ${FILESDIR}/nntpcached.rc > ${WRKSRC}/nntpcached.sh
-
post-install:
+ @ ${MKDIR} ${PREFIX}/etc/rc.d
+ @ ${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${FILESDIR}/nntpcached.rc \
+ > ${WRKDIR}/nntpcached.sh
+.if !defined(BATCH)
+ @ ${ECHO} "Installing ${PREFIX}/etc/rc.d/nntpcached.sh startup file"
+.endif
+ @ ${INSTALL_SCRIPT} -m 751 ${WRKDIR}/nntpcached.sh \
+ ${PREFIX}/etc/rc.d
+ @ ${MKDIR} ${NNTPSPOOLDIR} && ${CHMOD} 750 ${NNTPSPOOLDIR}
+ @ ${CP} ${PREFIX}/etc/${PORTNAME}/VERSION ${NNTPSPOOLDIR} && \
+ ${CHMOD} 640 ${NNTPSPOOLDIR}/VERSION
+ @ ${CHOWN} -R news:news ${NNTPSPOOLDIR}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/nntpcache
- for i in ${DOCS}; do \
- ${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/share/doc/nntpcache; \
- done
+ @ ${MKDIR} ${DOCSDIR}
+ @ cd ${WRKSRC} && find ${DOCS} \
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
.endif
- ${INSTALL_SCRIPT} ${WRKSRC}/nntpcached.sh \
- ${PREFIX}/etc/rc.d/nntpcached.sh.sample
- @${SED} -e 's#/usr/local#${PREFIX}#' ${PKGMESSAGE}
-
-hardlink-pgp-files:
- for i in ${PREFIX}/etc/nntpcache/*asc-dist ${PREFIX}/etc/nntpcache/*pgp-dist ; do \
- j=`${ECHO} $$i | ${SED} -e 's/-dist//'`; \
- if [ \! -f $$j ]; then \
- ${LN} $$i $$j; \
- fi; \
- done
.include <bsd.port.mk>