summaryrefslogtreecommitdiff
path: root/net/xmule/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/xmule/Makefile')
-rw-r--r--net/xmule/Makefile27
1 files changed, 7 insertions, 20 deletions
diff --git a/net/xmule/Makefile b/net/xmule/Makefile
index 24096a572b1d..b7edd2ff5cec 100644
--- a/net/xmule/Makefile
+++ b/net/xmule/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmule
-PORTVERSION= 1.6.0
-PORTREVISION= 1
+PORTVERSION= 1.6.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xmule
@@ -20,13 +19,14 @@ COMMENT= Port of eMule eDonkey P2P client using wxWindows class library
LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
expat.4:${PORTSDIR}/textproc/expat2 \
- wx_gtk-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk
+ wx_gtk2-2.4:${PORTSDIR}/x11-toolkits/wxgtk2
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GNOME= gnomehier \
gnomehack \
+ gtk20 \
gnomeprefix
USE_REINPLACE= yes
USE_GMAKE= yes
@@ -37,7 +37,9 @@ CONFIGURE_ARGS= --without-included-gettext \
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-WX_CONFIG?= ${X11BASE}/bin/wx-config
+WX_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
+
+wx_gtk2-2.4:${PORTSDIR}/x11-toolkits/wxgtk2
post-patch:
# it works for FreeBSD as well
@@ -74,19 +76,4 @@ post-install:
@${INSTALL_PROGRAM} ${WRKSRC}/src/ed2k \
${PREFIX}/bin/${PORTNAME}-ed2k-handler
-.include <bsd.port.pre.mk>
-
-.if exists(${WX_CONFIG})
-# detect if wxgtk was linked against gtk1 or gtk2
-DECISION_GTK_1_OR_2!= ${WX_CONFIG} --static --libs
-.else
-DECISION_GTK_1_OR_2= ""
-.endif
-
-.if ${DECISION_GTK_1_OR_2:M*glib-2.0} != ""
-USE_GNOME+= gtk20
-.else
-USE_GNOME+= gtk12
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>