summaryrefslogtreecommitdiff
path: root/net/xmlrpc++
diff options
context:
space:
mode:
Diffstat (limited to 'net/xmlrpc++')
-rw-r--r--net/xmlrpc++/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/net/xmlrpc++/Makefile b/net/xmlrpc++/Makefile
index 3c95fec30cf4..daa25cd2e693 100644
--- a/net/xmlrpc++/Makefile
+++ b/net/xmlrpc++/Makefile
@@ -18,9 +18,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ implementation of the XML-RPC protocol
USE_REINPLACE= yes
-USE_GCC= 3.1
+USE_GCC= 3.3
USE_GMAKE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 501103
+# Work around bsd.port.mk bug: Does not currently set up MAKE_ENV for gcc 3.2 and 3.3
+MAKE_ENV+= CC="${CC}" CXX="${CXX}"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|^CXX|#CXX|" -e "s|^CXXFLAGS|#CXXFLAGS|" \
-e "s|tests$$||" ${WRKSRC}/Makefile
@@ -30,4 +37,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/src/XmlRpc*.h ${PREFIX}/include/xmlrpc++
${INSTALL_PROGRAM} ${WRKSRC}/libXmlRpc.a ${PREFIX}/lib
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>