summaryrefslogtreecommitdiff
path: root/net/rdesktop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/rdesktop/Makefile')
-rw-r--r--net/rdesktop/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index 90e5e33ab04b..3cd6c9875285 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rdesktop
PORTVERSION= 1.4.0
-PORTREVISION?= 0
+PORTREVISION= 1
CATEGORIES= net comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,8 +19,12 @@ USE_XLIB= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_OPENSSL= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-x=${X11BASE}
+GNU_CONFIGURE= yes
+USE_ICONV= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -liconv
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
+ --with-x=${X11BASE}
DOCS= doc/AUTHORS doc/TODO doc/*.txt
MAN1= rdesktop.1