summaryrefslogtreecommitdiff
path: root/net/net-snmp/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/net-snmp/files')
-rw-r--r--net/net-snmp/files/patch-Makefile.top16
-rw-r--r--net/net-snmp/files/patch-ak21
-rw-r--r--net/net-snmp/files/patch-hr_disk.c19
-rw-r--r--net/net-snmp/files/patch-hr_storage.c24
-rw-r--r--net/net-snmp/files/patch-hr_swrun.c68
-rw-r--r--net/net-snmp/files/patch-local:Makefile.in18
-rw-r--r--net/net-snmp/files/patch-memory_freebsd2.c18
7 files changed, 82 insertions, 102 deletions
diff --git a/net/net-snmp/files/patch-Makefile.top b/net/net-snmp/files/patch-Makefile.top
index e6077bc203ef..7bb0b8a79ac8 100644
--- a/net/net-snmp/files/patch-Makefile.top
+++ b/net/net-snmp/files/patch-Makefile.top
@@ -1,11 +1,11 @@
---- Makefile.top.orig Sat Feb 16 10:00:19 2002
-+++ Makefile.top Sat Feb 16 23:31:00 2002
-@@ -52,7 +52,7 @@
- # Misc Compiling Stuff
- CC = @CC@
- # version number is prefixed by a 0 for a better shared library version number
--LIB_LD_CMD = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -rpath $(libdir) $(SHVFLAGS) -o
-+LIB_LD_CMD = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -rpath $(libdir) -release $(VERSION).0 -version-info 4 -o
+--- Makefile.top.orig Sat Apr 20 16:29:56 2002
++++ Makefile.top Tue Apr 23 08:53:54 2002
+@@ -60,7 +60,7 @@
+ # generally, LIBCURRENT should stay the same unless major changes occur.
+ # Increment REVISION every release.
+ # Increment AGE if new stuff is available.
+-LIB_LD_CMD = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -rpath $(libdir) -version-info $(LIBCURRENT):$(LIBREVISION):$(LIBAGE) -o
++LIB_LD_CMD = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -rpath $(libdir) -release $(LIBCURRENT) -version-info $(LIBCURRENT):$(LIBREVISION):$(LIBAGE) -o
LIB_EXTENSION = la
LIB_VERSION =
LIB_LDCONFIG_CMD = $(LIBTOOL) --mode=finish $(libdir)
diff --git a/net/net-snmp/files/patch-ak b/net/net-snmp/files/patch-ak
deleted file mode 100644
index 8a9d310cd7a0..000000000000
--- a/net/net-snmp/files/patch-ak
+++ /dev/null
@@ -1,21 +0,0 @@
---- agent/Makefile.in.orig Sun Nov 19 12:58:06 2000
-+++ agent/Makefile.in Wed Jan 17 18:37:02 2001
-@@ -68,10 +68,18 @@
-
- libucdagent.$(LIB_EXTENSION)$(LIB_VERSION): ${LLIBAGENTOBJS} libucdmibs.$(LIB_EXTENSION)$(LIB_VERSION)
- $(LIB_LD_CMD) libucdagent.$(LIB_EXTENSION)$(LIB_VERSION) ${LLIBAGENTOBJS} $(LIB_LD_LIBS)
-+ ld -Bshareable -soname libucdagent.$(LIB_EXTENSION)$(LIB_VERSION) \
-+ -o libucdagent.so ${LIBAGENTOBJS}
-+ ln -f libucdagent.so \
-+ ../libucdagent.so.4
- $(RANLIB) libucdmibs.$(LIB_EXTENSION)$(LIB_VERSION)
-
- libucdmibs.$(LIB_EXTENSION)$(LIB_VERSION): ${LMIBOBJS}
- $(LIB_LD_CMD) libucdmibs.$(LIB_EXTENSION)$(LIB_VERSION) ${LMIBOBJS} $(LIB_LD_LIBS)
-+ ld -Bshareable -soname libucdmibs.so.4 \
-+ -o libucdmibs.so ${MIBOBJS}
-+ ln -f libucdmibs.so \
-+ ../libucdmibs.so.4
- $(RANLIB) libucdmibs.$(LIB_EXTENSION)$(LIB_VERSION)
-
- clean:
diff --git a/net/net-snmp/files/patch-hr_disk.c b/net/net-snmp/files/patch-hr_disk.c
index b4f2c66a92f8..4afa759aafa6 100644
--- a/net/net-snmp/files/patch-hr_disk.c
+++ b/net/net-snmp/files/patch-hr_disk.c
@@ -1,11 +1,12 @@
---- agent/mibgroup/host/hr_disk.c.orig Tue Feb 26 01:57:26 2002
-+++ agent/mibgroup/host/hr_disk.c Fri Mar 29 16:06:29 2002
-@@ -185,7 +185,7 @@
- #elif defined(solaris2)
- Add_HR_Disk_entry ( "/dev/rdsk/c%dt%dd0s%d", 0, 1, 0, 15, "/dev/rdsk/c%dt%dd0s0", 0, 7 );
- Add_HR_Disk_entry ( "/dev/rdsk/c%dd%ds%d", 0, 1, 0, 15, "/dev/rdsk/c%dd%ds0", 0, 7 );
--#elif defined(freebsd4)
+--- agent/mibgroup/host/hr_disk.c.orig Sat Apr 20 16:30:03 2002
++++ agent/mibgroup/host/hr_disk.c Wed Apr 24 01:33:15 2002
+@@ -185,6 +185,9 @@
+ "/dev/rdsk/c%dt%dd0s0", 0, 7);
+ Add_HR_Disk_entry("/dev/rdsk/c%dd%ds%d", 0, 1, 0, 15,
+ "/dev/rdsk/c%dd%ds0", 0, 7);
+#elif defined(__FreeBSD__) && __FreeBSD__ >= 4
- Add_HR_Disk_entry ( "/dev/ad%ds%d%c", 0, 1, 1, 4, "/dev/ad%ds%d", 'a', 'h');
- Add_HR_Disk_entry ( "/dev/da%ds%d%c", 0, 1, 1, 4, "/dev/da%ds%d", 'a', 'h');
++ Add_HR_Disk_entry("/dev/ad%ds%d%c", 0, 1, 1, 4, "/dev/ad%ds%d", 'a', 'h');
++ Add_HR_Disk_entry("/dev/da%ds%d%c", 0, 1, 1, 4, "/dev/da%ds%d", 'a', 'h');
#elif defined(freebsd3)
+ Add_HR_Disk_entry("/dev/wd%ds%d%c", 0, 1, 1, 4, "/dev/wd%ds%d", 'a',
+ 'h');
diff --git a/net/net-snmp/files/patch-hr_storage.c b/net/net-snmp/files/patch-hr_storage.c
index 0c5381602966..3656d5a3a3d1 100644
--- a/net/net-snmp/files/patch-hr_storage.c
+++ b/net/net-snmp/files/patch-hr_storage.c
@@ -1,11 +1,11 @@
---- agent/mibgroup/host/hr_storage.c.orig Fri Feb 8 19:42:25 2002
-+++ agent/mibgroup/host/hr_storage.c Sat Feb 16 23:37:31 2002
-@@ -583,7 +583,15 @@
- for (i = 0; i < sizeof(mbstat.m_mtypes)/sizeof(mbstat.m_mtypes[0]); i++)
- long_return += mbstat.m_mtypes[i];
+--- agent/mibgroup/host/hr_storage.c.orig Sat Apr 20 16:30:03 2002
++++ agent/mibgroup/host/hr_storage.c Wed Apr 24 01:37:29 2002
+@@ -604,7 +604,15 @@
+ i++)
+ long_return += mbstat.m_mtypes[i];
#elif defined(MBSTAT_SYMBOL)
+#if !defined(__FreeBSD__) || __FreeBSD_version < 500021
- long_return = mbstat.m_mbufs;
+ long_return = mbstat.m_mbufs;
+#elif __FreeBSD_version < 500024
+ /* mbuf stats disabled */
+ return NULL;
@@ -14,14 +14,14 @@
+ return NULL;
+#endif
#elif defined(NO_DUMMY_VALUES)
- return NULL;
+ return NULL;
#else
-@@ -634,7 +642,15 @@
- + (mclpool.pr_nget - mclpool.pr_nput)
- * mclpool.pr_size;
+@@ -654,7 +662,15 @@
+ * mbpool.pr_size + (mclpool.pr_nget - mclpool.pr_nput)
+ * mclpool.pr_size;
#elif defined(MBSTAT_SYMBOL)
+#if !defined(__FreeBSD__) || __FreeBSD_version < 500021
- long_return = mbstat.m_clusters - mbstat.m_clfree; /* unlikely, but... */
+ long_return = mbstat.m_clusters - mbstat.m_clfree; /* unlikely, but... */
+#elif __FreeBSD_version < 500024
+ /* mbuf stats disabled */
+ return NULL;
@@ -30,5 +30,5 @@
+ return NULL;
+#endif
#elif defined(NO_DUMMY_VALUES)
- return NULL;
+ return NULL;
#else
diff --git a/net/net-snmp/files/patch-hr_swrun.c b/net/net-snmp/files/patch-hr_swrun.c
index c232386f873e..a2afd1c61cf3 100644
--- a/net/net-snmp/files/patch-hr_swrun.c
+++ b/net/net-snmp/files/patch-hr_swrun.c
@@ -1,43 +1,43 @@
---- agent/mibgroup/host/hr_swrun.c.orig Sat Feb 16 09:41:19 2002
-+++ agent/mibgroup/host/hr_swrun.c Sat Feb 16 23:41:05 2002
-@@ -543,7 +543,11 @@
- strcpy(string, proc_buf->p_user.u_comm);
+--- agent/mibgroup/host/hr_swrun.c.orig Sat Apr 20 16:30:03 2002
++++ agent/mibgroup/host/hr_swrun.c Wed Apr 24 01:43:15 2002
+@@ -557,7 +557,11 @@
+ strcpy(string, proc_buf->p_user.u_comm);
#endif
#elif HAVE_KVM_GETPROCS
+#if defined(freebsd5) && __FreeBSD_version >= 500014
+ strcpy(string, proc_table[LowProcIndex].ki_comm);
+#else
- strcpy(string, proc_table[LowProcIndex].kp_proc.p_comm);
+ strcpy(string, proc_table[LowProcIndex].kp_proc.p_comm);
+#endif
#elif defined(linux)
- sprintf( string, "/proc/%d/status", pid );
- if ((fp = fopen( string, "r")) == NULL) return NULL;
-@@ -638,7 +642,11 @@
- *cp1 = 0;
+ sprintf(string, "/proc/%d/status", pid);
+ if ((fp = fopen(string, "r")) == NULL)
+@@ -662,7 +666,11 @@
+ *cp1 = 0;
#endif
#elif HAVE_KVM_GETPROCS
+#if defined(freebsd5) && __FreeBSD_version >= 500014
+ strcpy(string, proc_table[LowProcIndex].ki_comm);
+#else
- strcpy(string, proc_table[LowProcIndex].kp_proc.p_comm);
+ strcpy(string, proc_table[LowProcIndex].kp_proc.p_comm);
+#endif
#elif defined(linux)
- sprintf( string, "/proc/%d/cmdline", pid );
- if ((fp = fopen( string, "r")) == NULL) return NULL;
-@@ -810,7 +818,11 @@
- }
+ sprintf(string, "/proc/%d/cmdline", pid);
+ if ((fp = fopen(string, "r")) == NULL)
+@@ -853,7 +861,11 @@
+ }
#else
#if HAVE_KVM_GETPROCS
+#if defined(freebsd5) && __FreeBSD_version >= 500014
+ switch ( proc_table[LowProcIndex].ki_stat ) {
+#else
- switch ( proc_table[LowProcIndex].kp_proc.p_stat ) {
+ switch (proc_table[LowProcIndex].kp_proc.p_stat) {
+#endif
#elif defined(dynix)
- switch ( lowpsinfo.pr_state ) {
+ switch (lowpsinfo.pr_state) {
#elif defined(solaris2)
-@@ -906,9 +918,17 @@
- proc_buf->p_stime*100;
+@@ -948,9 +960,17 @@
+ long_return = proc_buf->p_utime * 100 + proc_buf->p_stime * 100;
#endif
#elif HAVE_KVM_GETPROCS
+#if defined(freebsd5) && __FreeBSD_version >= 500014
@@ -47,17 +47,17 @@
+ proc_table[LowProcIndex].ki_paddr->p_iticks; */
+ long_return = 0;
+#else
- long_return = proc_table[LowProcIndex].kp_proc.p_uticks +
- proc_table[LowProcIndex].kp_proc.p_sticks +
- proc_table[LowProcIndex].kp_proc.p_iticks;
+ long_return = proc_table[LowProcIndex].kp_proc.p_uticks +
+ proc_table[LowProcIndex].kp_proc.p_sticks +
+ proc_table[LowProcIndex].kp_proc.p_iticks;
+#endif
#elif defined(linux)
- sprintf( string, "/proc/%d/stat", pid );
- if ((fp = fopen( string, "r")) == NULL) return NULL;
-@@ -976,6 +996,13 @@
- #elif HAVE_KVM_GETPROCS
+ sprintf(string, "/proc/%d/stat", pid);
+ if ((fp = fopen(string, "r")) == NULL)
+@@ -1022,6 +1042,13 @@
#if defined(freebsd3) && !defined(darwin)
- long_return = proc_table[LowProcIndex].kp_eproc.e_vm.vm_map.size/1024;
+ long_return =
+ proc_table[LowProcIndex].kp_eproc.e_vm.vm_map.size / 1024;
+#elif defined(freebsd5) && __FreeBSD_version >= 500014
+ /* XXX
+ long_return = proc_table[LowProcIndex].ki_vmspace->vm_tsize +
@@ -66,19 +66,19 @@
+ long_return = long_return * (getpagesize() / 1024); */
+ long_return = 0;
#else
- long_return = proc_table[LowProcIndex].kp_eproc.e_vm.vm_tsize +
- proc_table[LowProcIndex].kp_eproc.e_vm.vm_ssize +
-@@ -1237,8 +1264,13 @@
+ long_return = proc_table[LowProcIndex].kp_eproc.e_vm.vm_tsize +
+ proc_table[LowProcIndex].kp_eproc.e_vm.vm_ssize +
+@@ -1299,8 +1326,13 @@
#elif defined(solaris2)
- return proc_table[current_proc_entry++];
+ return proc_table[current_proc_entry++];
#elif HAVE_KVM_GETPROCS
+#if defined(freebsd5) && __FreeBSD_version >= 500014
+ if ( proc_table[current_proc_entry].ki_stat != 0 )
+ return proc_table[current_proc_entry++].ki_pid;
+#else
- if ( proc_table[current_proc_entry].kp_proc.p_stat != 0 )
- return proc_table[current_proc_entry++].kp_proc.p_pid;
+ if (proc_table[current_proc_entry].kp_proc.p_stat != 0)
+ return proc_table[current_proc_entry++].kp_proc.p_pid;
+#endif
#else
- if ( proc_table[current_proc_entry].p_stat != 0 )
- return proc_table[current_proc_entry++].p_pid;
+ if (proc_table[current_proc_entry].p_stat != 0)
+ return proc_table[current_proc_entry++].p_pid;
diff --git a/net/net-snmp/files/patch-local:Makefile.in b/net/net-snmp/files/patch-local:Makefile.in
index 1028734fb5b3..7f648103d7aa 100644
--- a/net/net-snmp/files/patch-local:Makefile.in
+++ b/net/net-snmp/files/patch-local:Makefile.in
@@ -1,11 +1,11 @@
---- local/Makefile.in.orig Thu Apr 4 15:04:11 2002
-+++ local/Makefile.in Thu Apr 4 15:04:17 2002
-@@ -2,7 +2,7 @@
-
+--- local/Makefile.in.orig Sat Apr 20 16:30:13 2002
++++ local/Makefile.in Wed Apr 24 01:45:55 2002
+@@ -12,7 +12,7 @@
+ # local info
+ #
SNMPCONFPATH=@SNMPCONFPATH@
-
--SCRIPTS=snmpcheck tkmib mib2c snmpconf
-+SCRIPTS=snmpcheck mib2c snmpconf
- PERLSCRIPTS=snmpcheck tkmib fixproc ipf-mod.pl rsnmp
+-PERLSCRIPTS=snmpcheck tkmib mib2c fixproc ipf-mod.pl snmpconf traptoemail
++PERLSCRIPTS=snmpcheck mib2c fixproc ipf-mod.pl snmpconf traptoemail
SCRIPTSMADEFORPERL=snmpcheck.made tkmib.made mib2c.made fixproc.made \
- ipf-mod.pl.made rsnmp.made snmpconf.made
+ ipf-mod.pl.made snmpconf.made traptoemail.made
+ PERLPROG=@PERLPROG@
diff --git a/net/net-snmp/files/patch-memory_freebsd2.c b/net/net-snmp/files/patch-memory_freebsd2.c
index e06a3266f224..8ddf778aea0d 100644
--- a/net/net-snmp/files/patch-memory_freebsd2.c
+++ b/net/net-snmp/files/patch-memory_freebsd2.c
@@ -1,11 +1,11 @@
---- agent/mibgroup/ucd-snmp/memory_freebsd2.c.orig Mon Sep 17 06:16:16 2001
-+++ agent/mibgroup/ucd-snmp/memory_freebsd2.c Mon Mar 4 10:00:56 2002
-@@ -232,7 +232,7 @@
- size_t total_size = sizeof (total);
- int total_mib[] = { CTL_VM, VM_METER };
+--- agent/mibgroup/ucd-snmp/memory_freebsd2.c.orig Sat Apr 20 16:30:08 2002
++++ agent/mibgroup/ucd-snmp/memory_freebsd2.c Wed Apr 24 01:49:01 2002
+@@ -274,7 +274,7 @@
+ size_t total_size = sizeof(total);
+ int total_mib[] = { CTL_VM, VM_METER };
-- long phys_mem;
-+ u_long phys_mem;
- size_t phys_mem_size = sizeof(phys_mem);
- int phys_mem_mib[] = { CTL_HW, HW_USERMEM };
+- long phys_mem;
++ u_long phys_mem;
+ size_t phys_mem_size = sizeof(phys_mem);
+ int phys_mem_mib[] = { CTL_HW, HW_USERMEM };