summaryrefslogtreecommitdiff
path: root/net/mute-net/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/mute-net/files')
-rw-r--r--net/mute-net/files/patch-MUTE::configure72
-rw-r--r--net/mute-net/files/patch-MUTE::layers::fileTransfer::Makefile.all11
-rw-r--r--net/mute-net/files/patch-MUTE::layers::pointToPoint::Makefile.all10
-rw-r--r--net/mute-net/files/patch-MUTE::layers::pointToPoint::pointToPointCommunicator.cpp19
-rw-r--r--net/mute-net/files/post-configure_patch-MUTE::layers::messageRouting::Makefile35
-rw-r--r--net/mute-net/files/wrapper.sh37
6 files changed, 184 insertions, 0 deletions
diff --git a/net/mute-net/files/patch-MUTE::configure b/net/mute-net/files/patch-MUTE::configure
new file mode 100644
index 000000000000..1a3b1934babd
--- /dev/null
+++ b/net/mute-net/files/patch-MUTE::configure
@@ -0,0 +1,72 @@
+--- MUTE/configure.orig Mon Dec 15 13:17:49 2003
++++ MUTE/configure Fri Dec 19 23:19:02 2003
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ #
+ # Modification History
+@@ -31,23 +31,9 @@
+
+ while [ -z "$userEntry" ]
+ do
+- echo "select platform:"
+-
+- echo " 1 -- GNU/Linux X86"
+- echo " 2 -- GNU/Linux PPC"
+- echo " 3 -- FreeBSD X86"
+- echo " 4 -- MacOSX"
+- echo " 5 -- Solaris"
+- echo " 6 -- Win32 using MinGW"
+- echo " q -- quit"
+-
+- echo ""
+- echo -n "> "
+-
+- read userEntry
+-
++userEntry=3
+
+- if [ "$userEntry" == "q" ]
++ if [ "$userEntry" = "q" ]
+ then
+ exit
+ fi
+@@ -55,12 +41,12 @@
+
+ # use ASCII comparison.
+
+- if [[ "$userEntry" > "6" ]]
++ if [ "$userEntry" -gt "6" ]
+ then
+ userEntry=""
+ fi
+
+- if [[ "$userEntry" < "1" ]]
++ if [ "$userEntry" -lt "1" ]
+ then
+ userEntry=""
+ fi
+@@ -316,20 +302,10 @@
+ esac
+
+
+-echo ""
+-echo ""
+-echo "Enter full path to wxWindows wx-config script."
+-echo " Example: /usr/bin/wx-config"
+-echo "To us the default setting, or if you do not plan to build the"
+-echo "wxWindows-based GUI, leave this blank."
+-
+-echo ""
+-echo -n "> "
+-
+-read userEntry
++userEntry=%%WX_CONFIG%%
+
+
+-if [ "$userEntry" == "" ]
++if [ "$userEntry" = "" ]
+ then
+ userEntry="/usr/bin/wx-config"
+ fi
diff --git a/net/mute-net/files/patch-MUTE::layers::fileTransfer::Makefile.all b/net/mute-net/files/patch-MUTE::layers::fileTransfer::Makefile.all
new file mode 100644
index 000000000000..cbba317c99e7
--- /dev/null
+++ b/net/mute-net/files/patch-MUTE::layers::fileTransfer::Makefile.all
@@ -0,0 +1,11 @@
+--- MUTE/layers/fileTransfer/Makefile.all.orig Sun Dec 21 01:05:38 2003
++++ MUTE/layers/fileTransfer/Makefile.all Sun Dec 21 01:05:56 2003
+@@ -50,7 +50,7 @@
+
+ # targets
+
+-all: libmuteFileTransfer.a test/testFileTransfer
++all: libmuteFileTransfer.a
+ clean:
+ rm -f ${DEPENDENCY_FILE} ${LAYER_OBJECTS} ${TEST_OBJECTS} ${NEEDED_MINOR_GEMS_OBJECTS} libmuteFileTransfer.a test/testFileTransfer
+
diff --git a/net/mute-net/files/patch-MUTE::layers::pointToPoint::Makefile.all b/net/mute-net/files/patch-MUTE::layers::pointToPoint::Makefile.all
new file mode 100644
index 000000000000..7db95eebf9e9
--- /dev/null
+++ b/net/mute-net/files/patch-MUTE::layers::pointToPoint::Makefile.all
@@ -0,0 +1,10 @@
+--- MUTE/layers/pointToPoint/Makefile.all.orig Sun Dec 21 00:53:18 2003
++++ MUTE/layers/pointToPoint/Makefile.all Sun Dec 21 00:53:26 2003
+@@ -34,6 +34,7 @@
+ LAYER_OBJECTS = ${LAYER_SOURCE:.cpp=.o}
+
+ NEEDED_MINOR_GEMS_OBJECTS = \
++${SHA1_O}
+
+
+ CRYPTO_LIB = ${ROOT_PATH}/MUTE/crypto/libcrypto.a
diff --git a/net/mute-net/files/patch-MUTE::layers::pointToPoint::pointToPointCommunicator.cpp b/net/mute-net/files/patch-MUTE::layers::pointToPoint::pointToPointCommunicator.cpp
new file mode 100644
index 000000000000..9bec3d21a8ad
--- /dev/null
+++ b/net/mute-net/files/patch-MUTE::layers::pointToPoint::pointToPointCommunicator.cpp
@@ -0,0 +1,19 @@
+--- MUTE/layers/pointToPoint/pointToPointCommunicator.cpp.orig Sun Dec 21 00:02:08 2003
++++ MUTE/layers/pointToPoint/pointToPointCommunicator.cpp Sun Dec 21 00:32:22 2003
+@@ -1153,7 +1153,7 @@
+
+ // handler to receive all messages from the routing layer
+ // extra argument not used
+-void mute_internalLowLevelMessageHandler( char *inFromAddress,
++int mute_internalLowLevelMessageHandler( char *inFromAddress,
+ char *inToAddress,
+ char *inBody,
+ void *inExtraArgument ) {
+@@ -1544,6 +1544,7 @@
+ delete [] *( tokens->getElement( i ) );
+ }
+ delete tokens;
++ return (0);
+ }
+
+
diff --git a/net/mute-net/files/post-configure_patch-MUTE::layers::messageRouting::Makefile b/net/mute-net/files/post-configure_patch-MUTE::layers::messageRouting::Makefile
new file mode 100644
index 000000000000..bd4ee53ae7bb
--- /dev/null
+++ b/net/mute-net/files/post-configure_patch-MUTE::layers::messageRouting::Makefile
@@ -0,0 +1,35 @@
+--- MUTE/layers/messageRouting/Makefile.orig Sat Dec 20 00:01:04 2003
++++ MUTE/layers/messageRouting/Makefile Sat Dec 20 00:02:01 2003
+@@ -532,10 +532,10 @@
+
+ # targets
+
+-all: libmuteMessageRouter.a test/testMessageRouter test/testMessageRouter2 test/testTalker test/testBystander test/testCatcher
++all: libmuteMessageRouter.a test/testMessageRouter2 test/testTalker test/testBystander test/testCatcher
+
+ clean:
+- rm -f ${DEPENDENCY_FILE} ${LAYER_OBJECTS} ${TEST_OBJECTS} ${NEEDED_MINOR_GEMS_OBJECTS} libmuteMessageRouter.a test/testMessageRouter test/testMessageRouter2 test/testTalker test/testBystander test/testCatcher
++ rm -f ${DEPENDENCY_FILE} ${LAYER_OBJECTS} ${NEEDED_MINOR_GEMS_OBJECTS} libmuteMessageRouter.a test/testMessageRouter2 test/testTalker test/testBystander test/testCatcher
+
+
+
+@@ -576,7 +576,6 @@
+ s/^SecureInputStream.o/$${STREAM_PATH}\/SecureInputStream.o/; \
+ s/^SecureOutpuStream.o/$${STREAM_PATH}\/SecureOutputStream.o/; \
+ s/^SecureStreamFactory.o/$${STREAM_PATH}\/SecureStreamFactory.o/; \
+-s/^testMessageRouter.o/test\/testMessageRouter.o/; \
+ s/^testMessageRouter2.o/test\/testMessageRouter2.o/; \
+ s/^testTalker.o/test\/testTalker.o/; \
+ s/^testBystander.o/test\/testBystander.o/; \
+@@ -585,9 +584,9 @@
+
+
+ # build the dependency file
+-${DEPENDENCY_FILE}: ${LAYER_SOURCE} ${TEST_SOURCE}
++${DEPENDENCY_FILE}: ${LAYER_SOURCE}
+ rm -f ${DEPENDENCY_FILE}
+- ${COMPILE} -I${ROOT_PATH} -MM ${LAYER_SOURCE} ${TEST_SOURCE} >> ${DEPENDENCY_FILE}.temp
++ ${COMPILE} -I${ROOT_PATH} -MM ${LAYER_SOURCE} >> ${DEPENDENCY_FILE}.temp
+ cat ${DEPENDENCY_FILE}.temp | ${MESSAGE_ROUTING_SED_FIX_COMMAND} >> ${DEPENDENCY_FILE}
+ rm -f ${DEPENDENCY_FILE}.temp
+
diff --git a/net/mute-net/files/wrapper.sh b/net/mute-net/files/wrapper.sh
new file mode 100644
index 000000000000..ed905246f9be
--- /dev/null
+++ b/net/mute-net/files/wrapper.sh
@@ -0,0 +1,37 @@
+#!/bin/sh
+
+PREFIX="%%PREFIX%%"
+PROGRAM="${0}"
+DIRNAME="${HOME}/.mute-net/%%INTERFACE%%"
+DIR_FILES="${DIRNAME}/files"
+DIR_SETTINGS_ORIGINAL="%%DATADIR%%/%%INTERFACE%%_settings"
+DIR_SETTINGS="${DIRNAME}/settings"
+
+if [ ! -d ${DIRNAME} ]
+then
+ mkdir -p ${DIRNAME}
+fi
+
+if [ ! -d ${DIR_FILES} ]
+then
+ mkdir -p ${DIR_FILES}
+fi
+
+if [ ! -d ${DIR_SETTINGS} ]
+then
+ mkdir -p "${DIR_SETTINGS}"
+ cp -R "${DIR_SETTINGS_ORIGINAL}/." "${DIR_SETTINGS}"
+fi
+
+if [ ! -h ${DIRNAME}/${PROGRAM##*/} ]
+then
+ ln -sf ${PREFIX}/bin/${PROGRAM##*/}-real ${DIRNAME}/${PROGRAM##*/}
+fi
+
+echo " ${*} " | grep " \-createdironly " ||
+{
+ cd ${DIRNAME} &&
+ echo Running under ${DIRNAME} &&
+ exec ./${PROGRAM##*/} "${@}" ||
+ echo PROBLEM. Cannot create directory ${DIRNAME}, make sure you have the proper permissions to create it and try again
+}